Quantcast
Jump to content

moosejaa

Members
  • Content Count

    14
  • Joined

  • Last visited

Community Reputation

0 Neutral

About moosejaa

  • Rank
    Occasional Poster

Recent Profile Visitors

162 profile views
  1. Popped the headlight and housing right out of the quad doing some riding in the woods...not me, the wife and her brother. Guess they thought it was OK to drive into small trees [emoji89]. It was secured with 4 plastic brackets, 3 of them broke. I'm having trouble finding a replacement part online. Headlight still works. Any suggestions for securing it...bungee chords, gorilla tape? Jk Sent from my SM-G960U using Tapatalk
  2. Got it started with the pull chord. Wish this thing had a pressure regulator, that pull chord is brutal. Ran for a few days and now won't start again. Thinking sparkplug or carb but I'll let the Kymco dealer handle that after seeing where the sparkplug was located. Sent from my SM-G960U using Tapatalk
  3. Thanks for clarifying. Didnt they actually split off from Honda? Sent from my SM-G960U using Tapatalk
  4. So you say they suck and then say your friend had nothing but a good experience...which is it? They also provided parts for Honda and BMW. Sent from my SM-G960U using Tapatalk
  5. Picked this up at the end of October (2014). Ran well up till a couple days ago and now won't start. Turns over, but won't catch. It's been a really cold winter. Put some seafoam in but that didnt seem to help. Any thoughts? Sent from my SM-G960U using Tapatalk
  6. Just bought my first ATV and came across this site/forum. Small issue though. I'm registered through Tapatalk but it doesn't recognize my email on the actual site. Recognizes my username though. Can't reset my password and can't register. Contacted the admins but no response yet. Sent from my Moto G (4) using Tapatalk
  7. To where? Sent from my Moto G (4) using Tapatalk
  8. sorry my bad moosejaa No worries, buddy. I know you roll the dice on anything used, even more so on a lesser brand. Hoping it works out. Sent from my Moto G (4) using Tapatalk
  9. Kymco isn't Chinese and I understand they make parts for many of the big name reputable brands. Sent from my Moto G (4) using Tapatalk
  10. Thanks, I'll take it. The one I picked up is used so hoping I don't run into too many issues. Sent from my Moto G (4) using Tapatalk
  11. Picked this up last weekend. Can't wait to get it down to the land. Sent from my Moto G (4) using Tapatalk
  12. This is interesting and confusing. My neighbor said around 7 PSI. Now the side of the tire says do not inflate above 36 PSI and the manual said keep at low 30s. Why would there be such a discrepancy? Sent from my Moto G (4) using Tapatalk
  13. Thanks! I did notice a little rattle/ping in the engine, sounds like a heat shield but it's not. Doesn't seem to effect anything and the previous owner drove it with no issues. Any thoughts? Sent from my Moto G (4) using Tapatalk
  14. Just picked up a used Kymco MXU 500 IRS. Found nothing but positive reviews and really enjoyed talking it for a test drive. Sent from my Moto G (4) using Tapatalk

×
×
  • Create New...