Fmarshall04

Kazuma Meerkat 50cc - Hard Starting

2 posts in this topic

Just picked up what I believe is a Kazuma Meerkat 50. It has spark, fuel getting to plug, just will not fire up. It has no visible kiddy kill switch or rear brake light assemble. Not sure what the issue may be I'm used to my 2stroke atvs. Trying to get this up and running for my son. Are there any wiring diagrams out there or carb settings, ie the air fuel screw. Thanks

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Suzuki24
      I have an 04 ltz and it started sputtering a little bit while going down the road and I was low on gas so I just figured that's what it was. But now I can't get it to start I completely cleaned the carberator put a new spark plug and coil pack in it and all it does is turn over. It has compression it's getting fuel and it is sparking but all it does is turn over any idea what it is??
    • By izzydum1
      Any ideas on what would make a coil not fire? She was running fine, then began slow start. Now wont start at all.
    • By Ironfist104
      My wolverine has a new carb kit, new battery cranks over and over take it to the point of killing the battery to start sometime.... but it I give a tug on the start rope while I'm cranking it with the starter it fires right up.... any advice?
    • By Percherongal
      Turn on key, put it in Neutral, lights on steering column light up. NO head lights and the electric start switch will not work. Let is sit for a few hours, started right up. Sat over night and same issue. Checked fuses and they were good. Battery is giving 12 volts. Opened up the ignition assembly and it isnt getting any power it comes up as a .01 on the volt meter. Pulled the spark plug to check for spark and NO spark. Will not pull start either. Unhooked the battery checked the spark while trying to pull start it and got a weak spark.
      Pushed it into the garage and it sat for 2 days. Turned the key and pushed the start button and it cranked but the spark plug wire was off so plugged the spark plug back in and pushed the start button and nothing. If you jump the solenoid it will crank over but not start. Soo confused , anyone have any ideas?