Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Racer944

Install a winch on 2003 Magnum 330 2x4?

Recommended Posts

Hi Folks;

Has anybody on here installed a winch on a 2003 Magnum 2x4? I am using a Cycle Country adapter plate (only one I could find), but am having a bit of trouble getting it all to fit properly, and am looking for someone that may have done this install and/or may have some pics of the installation.

Thanks!

Eric

Share this post


Link to post
Share on other sites


Thanks... I saw that but it seems it is out of production and no one lists it as available any longer...

Cheers;

Eric

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Tahj
      I bought a 2003 Recon from a kid that beat it – all plastics cracked etc, When I replaced the rear brake the inside – axle, rear oil  - were clean and in good shape, so I think Honda won the kid vs quad battle.
      It shifts a little clunky (I made the adjustment) and after riding for a while I get a hot friction material smell I wonder if he used the wrong oil and if any damage was done.
    • By Monika Novakov
      I have a 1988 Kawasaki 220 bayou. I removed the skid plate and misplaced the 4 bolts. Anyone know the size of these bolts, 3 dealers could not find any information. Can you please help?
    • By HeWasRidinDirty
      I got this 400, that wouldn't start. It would try, but wouldn't catch. I checked the valves and the L intake was tight at .002. The compression came in around 120. It didn't improve after a couple of drops of oil into the cylinder. So,I figured it was the valve causing the problem. So, I got the valves squared away, but it still won't start. I checked the spark and it seems like it's getting an intermittent spark. It fires a few times then nothing. If l let up on the button and then hit again immediately, it will fire a few more times, then repeat. So, what am I looking at as a possibility? Electrical issues are not my strong point. LOL
    • By Larry Fox
      Looking for the wiring diagram of the gauge cluster. Thinking about using it on my 2008 that I just bought.. Its gauge is destroyed
    • By davefrombc
      View File 1999 Polaris Magnum 500 Wiring Diagram
      Wiring diagram for 1999 Polaris 500Magnum
      Submitter davefrombc Submitted 09/08/2019 Category Polaris ATV  
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      There are many ways to install grips and make them stick. The best one, short of having grip glue, is to use carb cleaner. First, clean your handlebars with carb cleaner and a rag, then spray the inside of the grips liberally. The carb spray acts as a lubricant first and then actually melts the grips enough so that it will bond to the clean handlebar. This works great for all but the most extreme conditions. If wet weather is involved, you really need to use grip glue, and in addition, you should follow that up with some safety wire.
      QUAD off-road magazine
    • By Chayse Hill
      I have a 2003 LTZ 400 that i bought a few days ago. The quad was running fine until last night. I let my brother ride it down the street and back and i didnt notice anything etong with bike. Then my neighbors friend came over and said "can i ride it?" I said "sure" so he ripped it down the road all fine and when he got back it died right in front of us. My brother said it was dieing on him also. He also said that he wasnt using the clutch to shift. I told him he was an idiot. Im throwing that in there incase that caused a problem as well. But today i go to check it to make sure its getting fuel which it is and replaced the spark plug incase it wasnt getting spark but it is. So i started it and it was having a problem starting then i got started and was reving at idle high. So i took it around the block and it died on me a little bit down, so i try to restart it and it started so i kicked it into 1st and it kinda launched on me and started going with the clutch all the way in. Then it died right after and wasnt running right during that process and was idleing all over the place and just died and now i cant get it started it again. Before it would start without the choke or priming it. It would start real quick now i cant figure if it needs to be rejetted or something else. Air filter looks clean also. But any help would be gratelly appreciated!
    • By mallen14
      Looking for anybody who can point me towards a free service manual for 1998 Big Bear 350. I found the sticky thread but all the links, from 2012, no longer work. If anybody has one please let me know. Thanks
    • By Beb1041
      Looking for a download of a manual
    • By Wonderwoman
      Hello, well back to where I was last year with this carb. Took my 250 to the mountains for the first time this year and blue smoke, too much gas again. I can't believe that this carb gives me this much trouble. Seems like the choke is stuck but the cable moves freely. Anyone else ever experience this issue? Do you think a new choke cable would maybe resolve this?http://www.quadcrazy.com/atvforum/images/smilies/arghh.gif
      OK it was the choke. Put on all new cable and plunger and she is running 100% again. So now the question is, is the carb getting worn out where the plunger needle goes in the small hole and when I use the choke the needle end doesn't get lined back up with the hole?? We'll see how it runs and now that I know what the issue is I can always pull the choke plunger out and reinstall if I start having this issue again.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...