Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Last Dune trip !!


Recommended Posts

Dream Car Giveaway

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By slide187
      So I changed out the steel winch cable on my CForce 800-2 to a synthetic I had gotten when I had my old outlander and just never put it on. That wasn’t too difficult but I had to open up the hole in the spool a bit to get the tail thru. But I got it thru put the set screw back in and wound it up. It’s one of those Amsteel type cables, 50’ with an 8’ sliding protection sleeve on the hook end. And I put on an aluminum hawse with a rubber stopper and new hook. (Which is like the Warn Epic hook. Might be a little big. Haha ¯\_(ツ)_/¯)
       

       
      And right before that, I pulled out the halogen headlights. Replaced them with these nifty dual color LEDs. (But because of the heat sinks on them I had to widen out the holes for the bulbs a little and then vacuum all the dust out of the light housing with an improvised headlight vacuum. Haha)
      But they fit and the lights are yellow on regular beam and high beam switches them white).
       


       
       
      Sent from my iPhone using Tapatalk
    • By Freedomflyer
      Had the privilege to get out both days this weekend,  weather was fantastic. Was able to take my oldest brother out to an area he hadn't been to yet, and was thankful that we got to spend that time together just the two of us. I did ask some others to go but they were unable to make it so it ended up making a special day for us. His health is not the greatest so will definitely treasure the time and memories of this outing.  Was also able to finally link up with my neighbor and some friends of theirs and take them on one of our favorite trails today. They seem to be gone most weekends over the summer so has been tough to connect over the past 4 years since they bought their Razors. They seem to stick pretty close and go riding and camping together most weekends.  With fall setting in and it dipping into the high 20's and low low 30's at night, our camping season is coming to a close. Still in the 50's - 70's during the day but pretty chilly at night. They had a free weekend so we were finally able to take advantage and get out. Today confirmed for me, once again, why we haven't moved to the sidexside realm yet.  We were going to ride on one trail, and even though they have 50" machines. The trailheads have huge rocks, posts, or  arched cattle guard type gated areas that are exactly 50" apart.  This keeps the larger sized SxS's, jeeps and other 4 wheel drive vehicles off the trails and from getting torn to shreds. My wife and I drove our ATV'S through and friends attempted to do the same.  Even though the posts were 50" apart and perfectly plumb, the ground was sloped side to side  causing the fenders and door area to lean too far to the side and would have scratched the entire side of the machine as he drove through. He couldn't even get the front fender flair through with out it getting scraped and gouged by the wire of the fence wrapped around the posts. So had to change plans and go different route. Still ended up being a terrific day and they had a great time riding in a new area. No SxS for us in the near future!!! Here's some pics from  both days




















    • By Rich1028
      Silver Lake Sand Dunes 4-23-22 Part 1 of 3
       
    • By Rich1028
      Silver Lake Sand Dunes, Tour of the Dunes 4-23-22
       
       
    • Dream Car Giveaway
    • By freforall
      Hi i have a honda 350es 2002 4x4 (same as rancher but canadian edition). My problem is the clock and trip meter always resetting when i power off the bike. The trip meter reset to 0.0 and the clock flashing 1:00. The other function work normally gear shift, hourmeter and odometer. If i power off the bike for approx 2-5 seconds the clock and trip meter didnt reset. The battery is ok and all the fuse is ok. Can someone help me with this problem please. I found anything in my service manual.
      thanks
  • Gallery Images

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...