Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Hi my name is Travis and I live in South East MO and love my atv, it is a 05 Brute 750, with a H.l. 2"lift kit, 2"wheel spacers, H.L. 29.5 outlaws, H.l. Super duty clutch kit, Dyna jet jet kit, H.L. ecm power pac module, And full snorkels and radiator relocate. I race in competition and ride just for fun. SEMO Mudders - Your Online Mudding Community is my web site but it is under consstruction so don't expect much but you can check it out.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Airborne
      Hey guys/ gals 
      wife and i purchased 2 new machines in 2020, she actually surprised me when i said lets just look.  ....lol 
      next thing i know salesman called us saying our machines were ready for delivery,i fell in love w/ the kodiak 700; she got the 450. Both are the “ SE “ models , ..fast forward winch installed , plow ready for snow. I cannot praise it enough , however ill say theres times i will take her smaller quad out on trails and i actually enjoy it more lol , dont get me wrong the 700 is a Beast ...i pull trees outa woods, use it for multiple tasks on our property , its big.  Lol and the power was shocking ....then i hop on my wifes and its a different ride , almost feels like a snappy go cart in the woods. Lol.  It just goes and its fun to blast around on .... so i guess im lucky ..... 
      point here if your looking for nice machine for wife ,look hard at the 450 , power steering and plenty of power , weve met several people on trails and the question comes up “ how about a choice for my wife , we point them to this ..... 
      the Be ast is just amazing for work plowing snow is great, and it just works hard but loves to play ...... oh well just smiling with them figured id share some ramblings ...ride safe guys 
    • By Airborne
      Hows evryone feel about blasting around in snow ? 
      I love it usually after all plowing is done ill drop the plow and just go lut and have fun. From drifting all over lol to packing snow trails in woods its fun , never been into snow mobiles ,  where we live its very rural and our roads seem like an afterthought when it comes to plowing lol , usually last to get cleared , so we will hit the back roads to powerlknes and such , we have several people around here with side by siedes ,and the usually hit the powerlines , pack the trails and then we hit them good fun ....Anybody else ?
    • By jwline
      Friday evening went riding, rode for a good hour or so everything was fine. I went to take a short ride to the restroom (less than 100 yds away) and all of the sudden everything flickered and then just died out. Accompanying the problem I noticed the killswitch completely locked up. Once daylight hit took the killswitch apart to find it had shorted out and melted the plastic inside. Has anyone else had anything similar to this and if so what did you do to fix the situation? I have a new killswitch on the way to replace the obvious problem but was wondering could there be a bigger issue at hand. We tested with a voltage meter to make sure everything was still getting power from the battery and as far as we could tell it was.
      Any advice/info would be GREATLY appreciated.
      Thanks.
    • By coolcooch
      Hi everyone....I have 2006 750 Kawasaki Brute Force, my belt light came on, checked the belt, all's well there, I done this once before a long time ago, so long ago I can't remember how or what has to be done to get the light off. Yes I do have a tech manual, spent a lot of time looking for my answer to getting the light out, no luck. Too anyone that can help with this it would be much appreciated....Thanks
    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
  • Similar Tagged Content

    • By MuddyHound
      Hi! I own a 2013 Yamaha Raptor 125. Got it last week and im planning to upgrade some parts. Hope you guys can help and give me some tips. thanks!
    • By extremerider
      Hi guys! I am Tony. I own a 2012 Honda TRX250X.
    • By dontread
      Hello all I just acquired a 1986 YFM-200DX in not so bad shape I think at least doing a quick look over and for free what the heck. Thats where finding forums with people willing to share there subject matter knowledge and enjoy doing so is an awesome thing in life. so in a nut shell here I am, thank you all in advance
      Don
    • By bubbaca916
      Hello I am a newbie to this site and to quads in general I work on cars but never had the honor of working on a quad until now. I actually buy storage auctions and I moved a mattress and behind lays this BEAUTY LOL I am not sure the make model nothing I did however find a VIN i think I will post some pictures please be honest and tell me what you think should I try and fix it up which I am more than willing to do or just junk it thanks J.







    • By scrammy650
      hi there just joined .picked up a i think 2000 timberwolf 4x4 and i will be having a bunch of questions so hoping someone can chime in . looking forward to meeting some new people. i live in massena,ny
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...