Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Deerwhkr

2001 Polaris Magnum won't start

Recommended Posts

Installed new starter, new soleniod, cleaned battery terminal connections. When I hit the start button it sounds like battery is dead and won't crank the engine

Share this post


Link to post
Share on other sites


Is the battery fully charged? Sounds like it could be the battery or a bad connection. 

Share this post


Link to post
Share on other sites

My riding mower did this last year. Even tho I cleaned the terminals ,it wasn't good enough?  I re cleaned and re tightened and away she went

Share this post


Link to post
Share on other sites

If I am not mistaken, the solenoid is mounted to the metal battery box. The box acts as a ground to the solenoid mounting bracket. Ensure the area the solenoid is mounted to is clean. Or run a short ground cable from the negative battery terminal to the solenoid bracket. 

 

Share this post


Link to post
Share on other sites

Thanks for all of your help. The battery was the problem. Although it was 100% charged it could not handle a load. New battery and it starts great. 

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.


×