Quantcast
Jump to content


1994?? King quad 300? (not always starting and running)


Suzuki King quad 300  

1 member has voted

  1. 1. is this atv reliable

    • Reliable
      1
    • Not relliable
      0


Recommended Posts

so i recently got a Suzuki king quad from what i have discovered i think it is a 1994 300 but cannot find serial number i have a couple of questions one is, is the engine oil fill cap and dipstick under the rear right fender??, one other is does this machine have a clutch?? i am not sure if there are any common problems this machine starts and runs and can ride for 5 mins then will conk out and will not start again the spark plug will be wet when removed sometimes i have changed fuel and done other checks but am not sure what is wrong we thinks its carb is being flooded a bit, the old battery will not start it, it just clicks from up near the battery we have been jumping it off a 12v car battery which makes it turn over and sometimes start but about 75% of the time it doesn't does anyone know what might be wrong with it??

thanks Quad-Rider53 

IMG_20180225_180722[1].jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By NZrider
      My king quad 700 runs rough when cold then won't start some times but not often when it's hot. And occasionally smoke's a lot when it's cold I'm guessing that's rings but I'm worried unless it's causing the other problems
       
       
       
      All help is appreciated thanks
    • By Slitzer
      How often do you change oil in front/rear diffrentials and gearbox?
    • By hardcastle
      My friends KQ 300 starts fine and runs, as soon as you put it in gear and try to accelerate its bucks and farts like crazy, not moving... I cleaned carb and it worked good for 1 day... now back to same problem.... could it be such as a bent valve????
    • By Whiterabbit
      3500lb, synthetic rope lead and everything needed to install for........................................ $89 bucks!  I'm installing one on my '01 Bombardier Quest and it looks like a legit buy. If you have a RK nearby & you need a winch you might want to swing by before they disappear.
    • By cavry
      Wiring shows White and Brown to solenoid blades. Then a black wire from starter circuit relay to solenoid. I am confused,  where is that black wire supposed to connect?
      Thanks for any help
      Cavry
×
×
  • Create New...