Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Noticed a pretty big mistake in the video so here is the updated one!

Giving a Thumbs up on the video on youtube will help it rank higher on! Along with the watch time! If you liked the video please thumbs it up!
 
 
  • Like 1

Share this post


Link to post
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Resurgence Small Engine Inc.
      In this video, Jonathan diagnoses & repairs the decompression system on a Yamaha 2003 Grizzly 660.
      Some symptoms include: Pulling recoil right out of your hand, starter turning really slowly, constant dead batteries.
      Thanks for watching!
       
    • By crochet homemade
      I have bought a 1996 suzuki king quad 300 and I have noticed that it smokes but I have put oil in it and plenty of gas had to fix shifter bc the nuts and bolts came out somewhere. I have had to replace the wire for the starter but now when I try to start it it wont idle at all and when it does run it smokes really bad like a whitish blue I guess, and it likes to stall a lot. So anybody can help me out please and thank you

      10000000_310855426253462_714534016610467840_n.mp4
    • By TWiST
      New user and first time quad owner. I recently got a 2000 Polaris Sportsman 500 and am really excited to start working on it! I work in IT for a living and am an experienced mechanic, so at least I am not starting at 0 haha.  Looking forward to hanging out and getting to know everybody!
    • By BuckBilly
      ATV Shows
      Kind of slow to load up!
    • By bradleyheathhays
      '11 Grizz 700 here.  Since I've got some warm weather these next couple days I've decided to start the bike after about a year of just sitting.  Took out the plug and sprayed a good amount of fogging oil on top of the piston to help lubricate things.  After about a minute of letting it soak I stuck my air line tubing in to suck out the excess, but it seems like I didn't get nearly as much in return.  Repositioned the tube enough so that everything that was gonna come out pretty much did.  I'll probably shoot some compressed air down the plug hole before doing the start just to make sure it's all out, as well as cranking it for a second before putting the plug back in.   How long would it take for a bit of standing fogging oil to seep past the piston rings, and where would it go?  I guess into the engine oil?  The oil was fairly new the last time it was started but I'm sure it could stand to be changed after sitting for so long.  If much of this fogging oil got into the engine oil should I do the change before the startup?
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...