Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

VaderGriz

2009 Arctic Cat 90 not going into gear

Recommended Posts

The bike will go into gear after monkeying with the shift lever but then it's slow to engage. Feels like the clutch is weak. I've pulled the belt cover off and belt looks fine. Should i pull the sheave and regrease roller weights? change Trans fluid? Anyone had this issue?

Share this post


Link to post
Share on other sites


Ive never worked on the 90cc bikes, usually there is no separate transmission fluid. The oil does both jobs. The service manual is posted in a thread above so check that first.

If there is no transmission fluid, what it sounds like happened is the oil is not wet clutch compatible and will cause those symptoms. 

Mike

 

Share this post


Link to post
Share on other sites

any luck?

I know I had a friend that has a recon that wouldnt go into reverse-  this was because the idle was too high and the clutch was not disengaging at idle.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Arizona
      I have a couple other topics on this Bayou but this one is the reverse lever seal is leaking.
      Talked to the dealer and have no listing on the seal. Looks fairly simple but is the seal installed from
      the outside of crankcase or from the inside before I remove it.
      Next question where can I get the new part? I found these on ebay but not sure if they fit.
      any ideas where to buy it? https://www.ebay.com/itm/Kawasaki-KLF220-88-02-Bayou-KLF250-03-10-Winderosa-822138-Engine-Oil-Seal-Kit/352356942519?fits=Year%3A1995|Model%3ABayou+220|Make%3AKawasaki&epid=209928936&hash=item520a1c42b7:g:ZKUAAOSwx6pYooaN:sc:USPSFirstClass!78006!US!-1
       
       
    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
    • By stinky
      I have an Outlaw 110 that will struggle to turn the engine over. Jump starting doesn't help other than the battery will drain LONG before the bike eventually starts, so is required. If you keep messing with it long enough it will eventually magically begin to crank fine and sometimes finally start. Once we finally get the bike to start and warm it up thoroughly, it will turn over and start just fine the rest of the day like nothing ever happened... next day it won't turn over again.  Internet research has found lots of people saying they replaced starters, starter clutch, wiring, etc. but with only about 50/50 success rate for their particular problems... and I never found anybody describing a problem like mine, so I'm looking for advice/experience. Would rather not just start blindly throwing parts at it. Does anybody have any thoughts/ideas?
    • By Ulf Löfstedt
      I just bought a Yamaha Big Bear 350 from 1992. The previous owner has run it on regular engine oil and I have problems with the clutch slipping. I think that's the reason.
      So what should I do?
      - Just change oil and it will be OK?
      - Clean engine/clutch + new oil?
      - Or do I need a new clutch?

      It is guessing the centrifugal clutch that slips. It has two clutches , it also has a "regular" clutch .
      Anyone who has any experience of using wrong type of oil?
    • By Gordon cousins
      Hi bought old Yamaha 1990 big bear  Guy took off  gear selector  and lost it anyone know were I con locate one  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...