Quantcast
Jump to content


Suzuki King Quad 300 Slow Running


Wolds Alpacas

Recommended Posts

I have just ordered a Suzuki King Quad 300 which should be here this week - it is described as "with slow running needing attention"  I am as a matter of course going to put a new spark plug in, change the oil and oil filter and blow out the air filter with compressed air - anything else I should consider?  Also, the headlights do not work - I want to change them out for LED ones anyway though. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By JohnnyB
      Greetings, 
      Have a 88 LT80 that been sitting for a couple years. Bought a new piston, cylinder and head. Installed these, rolled it over and it quickly locks up.  Took carb apart. It was full of what appears to be 2 cycle oil. Cleaned it, but keeps locking up and 2 cycle oil continues to seap from exhaust port.  When i installed new cylinder, I noticed crankcase was full of oil.  I'm now wondering if that oil is what's getting sucked up into cylinder.  Should there be no oil in crankcase?  If that the case, how is crank and rod lubricated?  Sorry, never worked on a 2 stroke. Thanks!
    • By justent_88
      Hello, im looking for some input on this situation i have. My 94 Mojave has no spark, and i have no idea what it is. Ive replaced/tested the magneto, the pickup coil, cdi, the ignition coil. Even the key and Killswitch. I haven't tested the harness its self, but i have tried another harness and still nothing. The only thing i can think of is the fly wheel itself. I have found a lot of metal shavings in the fly wheel and have cleaned it the best I could. But nothing happened afterwards. I am truly stumped here and hoping some of yous could shed some knowledge/ideas that could help get this thing to fire. 
    • By mga
      I see quite a few ads for that  Tribotex additive. It's kind of expensive, has anyone used it it their ATV or any other vehicle?
    • By cavry
      Wiring shows White and Brown to solenoid blades. Then a black wire from starter circuit relay to solenoid. I am confused,  where is that black wire supposed to connect?
      Thanks for any help
      Cavry
    • By NZrider
      My king quad 700 runs rough when cold then won't start some times but not often when it's hot. And occasionally smoke's a lot when it's cold I'm guessing that's rings but I'm worried unless it's causing the other problems
       
       
       
      All help is appreciated thanks
×
×
  • Create New...