Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

JacobSlabach

Yamaha Warrior clutch/carb/exhaust issues

Recommended Posts

whats the clutch actuator again?  I found part of the issue was that the linkage inside the clutch cover was not adjusted to the right gear tooth, but now it feels as if the clutch is locked up.

Share this post


Link to post
Share on other sites


figured out the issue- just the incorrect tooth on the linkage.  Jumped the bike and took it for a ride (strained the oil, cleaned the oil filter, and put it back in).  the clutch seems jumpy like it engages all the way at about 3/4 way out.  And it doesnt like shifting into neutral when running and when its off, neutral is between 1st and 2nd gear...??? gonna order a new battery for it as every time i stall, it has to be jumped..no pull start.  also, i was thinking of getting a aftermarket air filter that attaches directly to the carb so i didnt need an air box.  is this a bad idea?  the old airbox melted on the exhaust.

but i'm still impressed as to how good this thing runs after having water in it.  has tons of power and endless rpm..  i haven't needed to use but about half throttle on it so far.

Share this post


Link to post
Share on other sites

Sounds good. Nice work.  If the clutch is grabbing 3/4 way out the clutch needs replacement plates and springs.  Not a big deal.  Yes is one down four up or five up whatever it is. When you want to go to neutral you go all the way down and a half click up, that’s neutral. 

You can def replace the air filter IF there is no breathers going to the existing air box.  I used one on my old Polaris 90.  It worked fine. Looked great too. But only if there is no breather connected. 

Share this post


Link to post
Share on other sites

ok.  are replacement clutches expensive?  Thats weird that neutral is where it is- any reason for this?  The bike has one breather, but is doesnt attach to the air box, it just sticks up under the plastics..  (maybe this is how the water got into the engine?)

Share this post


Link to post
Share on other sites

All bikes that I’ve ever known  even street bikes, Harley’s etc are like that.  

Look on amazon and you will see the air breathers. They look great.  You may have to adjust the air fuel screw a bit but that’s about it.    

 

Share this post


Link to post
Share on other sites


wait what are you talking about the air breathers?  I thought you were talking about the vent hoses coming into the airbox..

Share this post


Link to post
Share on other sites

My answer was you can add a stand alone breather to the back of the carburetor only if you don’t have an existing oil breather line going to the old air box. If that’s the case then you need to keep the existing type air box.   

I did this on my Polaris 90 and it worked.  I had to adjust the air fuel screw a little.   

This is the type I put on from amazon. 

45mm Universal fit"Turbine" Air Filter - Motorcycle Scooter Pocket Bike ATVs - Blue (Model 10410-02) https://www.amazon.com/dp/B01DWGRL14/ref=cm_sw_r_cp_api_i_6YseDbM4GBSQ3

Share this post


Link to post
Share on other sites

ohhh  ok thats what i thought.  so i think there IS a breather, but it didnt hook up to the old airbox nor was there a place for it to hook up.  it just stuck up and dead-ended under the gas tank..  i tucked it under the carb so it wouldnt collect rain (i believe this was how water got into the engine from sitting out for years).  anyway i bought a 45mm high flow filter for 20 and it looks beautiful!  sputtered at top end so i adjusted it richer like you said and now it runs great.  I was having issues with the clutch engaging to hard and stalling me but it softened up and is easy to drive now.

Picture0629191810951.jpg

so i put it up on CL today for $1700.  prolly have to drop the price but who knows....  almost want to keep it- its soo fun to rip around..  even just around my shed i was raising clouds of dust and making berms..

Share this post


Link to post
Share on other sites

oh and i took those ugly lights off and put on the lightbar that i used to have on my bayou on this bike:

20180424_073031.JPG

20180424_073059.JPG

20180424_073020.JPG

lol those are gopro pics- and its date is off.. i took those this afternoon

Edited by JacobSlabach
grammer

Share this post


Link to post
Share on other sites


yea, the plastics could use work but i just dont have time...  oh well

got two jobs and these projects...  another job next week.. lol

Share this post


Link to post
Share on other sites

so thanks to the forum for helping as i complete my first successful flip..  Yamaha runs great, now for the right sale price and shes gone..

Picture0706191231951.jpg

Share this post


Link to post
Share on other sites


 

btw heres a YouTube vid of the vid behind that..  amateur at wheelies- your seeing my first tries..

  • Like 1

Share this post


Link to post
Share on other sites

Hey so back to this bike..  turns out its sputtering high end and found out the air filter is too restrictive.  Also blew the axle bearing so I gotta replace that cause the chain is wayyyy too loose as is.  Any help on what air filter would work good on this?  It's almost like it needs a turbo haha.

And what's a good plastic cleaner for atvs?  It has mildew on it and some pine sap.

Share this post


Link to post
Share on other sites

Awesome thanks!!  And sorry to the forum, I really enjoy following along with all the threads and giving my 2 cents worth but just havnt made time..  school and all..

Share this post


Link to post
Share on other sites


So turns out I still got this bike.  One problem after another on it.  So I bought the stock airbox and air filter put that on and ran good.  Jb welded the hole in this side of the engine...but then I noticed the crankcase seal is leaking oil, and I was riding it one day and it started the old popped with throttle and started to try and seize up on me.  I had just added oil ( due to the leak) so I thought I was good on that

Turns out its spitting oil out the carb into the airbox as well as leaking out the crankcase.  Looks like I'll have to rebuild the top and bottom end...again.  not sure what went wrong? Lol. It still runs good cold.

I get the weirdest atvs... my old 500 ran great on diesel fuel and this bike runs good for ab 5 mins with no oil 🤣🤣🤣

Share this post


Link to post
Share on other sites

update here to close it our- i promise this is the last of this thread from me- lol

sold the bike with the oil leak for $550.  never tried to figure out where it was coming from.  trying to move these smaller project out to make some room for future builds..

Share this post


Link to post
Share on other sites

haha yea i was just going through my threads i had started and wrapping what i could up- cant stand unresolved threads

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By bellssn690
      Hello all. I'm a new owner of a like-new 2013 Rancher. I'm hoping to get enough information to keep/maintain my new atv. It's in great condition but I've noticed that it wants to die after running great for a while and I come to a stop. It's like it chokes itself out. Not sure why but it'll start up again but it's in such nice shape I want to make sure I keep it that way. Thanks for any advice and help in advance.
    • By Steven Urban
      First time using this forum.  Owned a Kawasaki dirt bike once, had no issues.  But I picked up this 4 wheeler at an auction.  They stated it ran, but only needed a battery.  Well I do not believe that was all true.

      Some pictures are attached.  Not sure why, but the whole air filter stuff was removed.  They had some small thing inserted as a make shift air filter.

      I purchased a battery to try this all out.  Waiting to return it and get the proper size, as it was too big for the battery box.  But here is my issue I had while the battery was connected.

      1 - The lights on the steering column did not come on.  Not sure if they work or not.

      2 - The starter solenoid seems to be bad.  I have a new one on order. 

      3 - In the pick, there is another rusted part.  Not sure what that part is or what it is used for.

      4 - What is the 12v rectifier?  square bodied part.

      So when I hooked the battery up.  Pushing the start button did nothing.  Pulling the cord to try and pull start, it turned, but would never fire.  I have put in a new spark plug as well, it looked worn out.  With electric start, I crossed over the posts on the start solenoid, it turned over, but would never fire and start.

      I have read a few other threads and it stated something about needed the neutral light on.  SOmething about a kill switch.

      Any help would be appreciated.



    • By Ajmboy
      Disconnected the plow yesterday on my 2004 Yamaha Grizzly 660 and am getting ready to do some riding yesterday and the battery went weak, Starter cranked a few times but week. Put my trickle charger on that I bought and went to the garage today to start it up, but the starter is just spinning and not engaging. The solenoid is clicking. The pull start sucks and is hard to pull (never use it and need to look into that). Quick video of the starter spinning. Could it be the starter or  the starter clutch one-way bearing? I guess I need to take the cover off to see what's going on.

      2004 Yamaha Grizzly 660 Starter Spinning.mp4
    • By Rigo Mena
      I have a Kawasaki bayou 220 that won’t start I don’t know if it has something to do with the electrical wires but when I put the screwdriver on both bolts of the relay it wants to crank but can’t and there’s a missing piece I think it’s another relay that has 6 wires going into it
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...