Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Michael Trinity

2007 xtreme typhoon 125cc Quad spark plug

Recommended Posts

Hey there.  I have a problem with finding the rite sparkplug for my 2007 xtreme typhoon 125cc.  No one or place has been able to find the right spark plug for it.  Im hoping someone here may have an idea or can point me in the right direction of where to find one.  The old one said ac 108 and one guy at an auto parts store said it was a 10mm spark plug.  Dont know if that was rite or not.  Also if anyone knows of a website i can download the manual for it, that would be very helpful as well. 

Share this post


Link to post
Share on other sites

1 hour ago, Michael Trinity said:

yes that be it.  Thanks so much.  Do u know where i could find a service manual for it.

No unfortunately, I looked online but didn't see one. 

Share this post


Link to post
Share on other sites

The gap is important but usually its not adjustable on the type of atv you have. You can measure the resistance of the coil, if its infinite resistance then the coil is bad

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By Chris2018
      I have a 1996 Kawasaki Mojave KSF250. I have no manual on it and it has a no spark issue. If anyone could give me a hand with this or would possibly have a manual would appreciate it. 
    • By JonBat68
      I have a 99 250 Quadrunner. Currently has no spark. It would run for 5 minutes, then shut off. After it cooled down about 20-30 minutes, it would start again. I ordered a new stator and found the old one was damaged (copper windings broken)  I installed the new stator, filled with oil and now it has no spark. Any assistance would be helpful
    • By Nick Gudex
      Hello I am new to this site and I havea problem. I have a 1987 big bear 4x4 that will not spark. I tested pick up coil per repair manual and I tested my new coil both ok. It puts out 9 volts at the coil but It is reversed polarity. So when I hook my meter up to it she shows -9 volts while cranking. When I put a test light  on it it flashes. Being an electric system this should tell me something but I don't know what its telling me. I have yet to meet one i could not fix but this old girl has me stumped. Any help would be awesome. Thanks to all.
      Nick
    • By Ailll1
      I’m working on a Kawasaki Bayou KLF400 for a family member that doesn’t have spark. I’ve already replace the ignition switch and the stator which were defective. The stator had a melted connector and one of the phase had low resistance and low VAC output. 
      What I’ve figured out so far is that I’m not getting 12V to the ignition coil when I turn the key to the ON position. From what I understand, the 12V should come from the CDI. I’ve resistance tested both wires going from the CDI to the ignition coil (Green/white and black/yellow). They are fine. The only 12V coming from the ECU is on the yellow/red wire.
      I don’t have the wiring diagram for the 400 but I’m working with the one for the Bayou 300 which looks pretty similar except for the wire color between the CDI and ignition coil. On the 300 diagram, the yellow/red wire goes to the ignition coil, not the black/yellow… All the other wires color match except for this one. Not sure if that’s normal?
      Thanks!
    • By yugnats
      Hi all, I was gifted this Bayou but she's been sitting quite some time. It won't crank using the factory start button but when I jumper the starter solenoid it cranks but there is no spark. The key has power coming in on the white wire and when turned on supplies power to the brown wire coming out.

      I guess I should start with testing the pickup? I heard I may be able to jumper the wires coming from the pickup with an LED bulb and it will flash? I noticed in the manual that it should have around 110 ohms resistance so I'll check that as well. One thing I noticed was that the starter circuit relay has power on one of the black wires with the key on- this doesn't seem normal as I'm assuming the black wires are grounds? I think one of them comes from the start switch, travels through the starter circuit relay and then grounds the starter relay?
      Mine is a 1991 so it has the 7 wire CDI (ignitor) and a 2 yellow wire alternator ( as opposed to the later 3 wire type ) with another 2 wires for the source coils (black & red wires ). The pickup wires are blue and black I do believe. Any help appreciated and yes I will test the pickup ASAP.

      I'm trying to understand how the system works and I don't understand what the yellow / red wire from the kill switch does- I assume it gets grounded when the kill switch is "on" and therefore grounds the CDI so it can't activate the ignition coil? I noticed in the diagram that that yellow / red wire looks like it may be grounded by the ignition key switch when in the "off" position?
      I also don't have 12v power at any of the wires going into the CDI- doesn't the CDI need to be powered? I also read on this forum that someone used a GM HEI module in place of the factory CDI just to test it for spark- does anyone have any info on that?

      I hope I'm not missing something simple!
      Here is a link to the diagram for my bike (which was posted by another user): https://www.quadcrazy.com/atvforum/topic/13742-1988-bayou-220-lost-spark/?tab=comments#comment-101193

      Any help appreciated!
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...