Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mike costa

2001 Kawasaki 300 Bayou winch mounting plate

Recommended Posts

Has any one tried using the Harbor Freight Winch mounting plate on a 2001 Kawasaki 300 4x4 Bayou? 

Share this post


Link to post
Share on other sites


Yes and it worked but !!!! BUT ! I had to reem all the holes out to make it fit. So a good drill bit and you will be good to go. 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By mike costa
      Motor starts right up, but when I open it up past quarter throttle it bogs way down while ridding, the longer it runs the worse it gets. If I just leave it in neutral and  give it full throttle it revs up and down. 
      Back history:
      Bike sat for 3 years,
      Installed new plug, cleaned the fuel tank, took it to a shop and had the carburetor gone though.
      Picked up from shop, motor bogged down first day and barely got me back to the truck an 1 mph.
      Took back to shop after a month I was told it had a bad plug, I told him I just replaced it.
      Got quad home and it is doing the same thing!!!!!!!!! 
       
      Thanks in advance for your support!
       
      The carburetor has recently been gone through by a shop
    • By MarkinAR
      Let me start with I have about 30 years of ATC experience, but not much with stuff made after 1988.  Some, but I'm mechanically inclined so it's all good.  I"m rehabbing a 1997 Bayou 220 to send back into the wild and the mechanicals are now all good, just working on making the electrical system...electric.  Right now, I have no power on the white wire as tested directly on the plug at the starter solenoid.  I'm assuming that wire is supposed to be hot any time it's attached to a battery?  The genius that had it before snipped a couple wires and inserted a fairly heavy push button for electric start bypassing the electrical system. I think i've corrected everything north of the solenoid but the white wire has me stumped.  Is my assumption that this should always be hot with a hot battery correct?  Does this indicate a broken circuit in the starter solenoid?  Relay was also bad and wired incorrectly, but that's resolved and I can make the relay click bypassing the solenoid and connector, directly giving the white wire 12V.  Thoughts?
    • By gouletp
      The thing sat since Christmas 2018 and while I decided whether to replace the starter (which I finally did today).  I am not sure if I added fuel stabilizer or not but chances are good I did.  I kept the one year-old battery well charged during the winter.  It turns over well but won't start.  I have a blue spark on a brand new plug.  When I pour a bit of fuel down the cylinder, the engine starts and runs for a few seconds (once for as long as about 8 sections) and then dies.  Even before adding fuel to the cylinder I noticed that the spark plug was wet with fuel.
      The air filter looks a bit dirty so I removed it just to see if the engine would start better but it made no difference.
      If the fuel did not contain stabilizer then the carb may be gummed up.  I don't really want to remove the carb to do a thorough cleaning.  Is there a product I can spray into the carb while the engine turns over that will clean the carb?
      Any other suggestions?
      Thank you
    • By Jeff Comstock
      Help a brother four legger out
       Bayou300 acts like it's flooding if it's it's in the Alabama sun all day but, I've cleaned the carb. Sometimes it'll backfire even though the timing and valve lash are in spec. Thought it was sticking float but after 2 times cleaning the carb I'm lost. So
    • By Slifer
      I have a Kawasaki Bayou 300.  When the four wheeler is idling it won't rev up and the spark plug fouls easy.  It acts like it has a rev limiter.  When I start it, it only runs about 5 minutes and then dies.  Anybody have any suggestions on what might be wrong with it and what it would take to fix this.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...