Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Rich1028

Road Leota Trail Yesterday

Recommended Posts

 

 

 

Road Leota Trail Yesterday 

this makes two weekends in a row,my third time,wife's second,she is getting more familiar with riding,need to look at getting Her a bigger machine!

Wife's Suzuki Ran Fine,no problems.

My Honda...Killed a wheel!

Leota Trails 9-7-19 099.jpg

 

I have A video  of our day.

 

Edited by Rich1028

Share this post


Link to post
Share on other sites

Very nice! What size bike is she riding now ? 

That rim if you heat it up and take a small sledge hammer/lump hammer wrap it in duct tape and slowly hit it back into shape.  Take your time.  

  • Like 1

Share this post


Link to post
Share on other sites

Or if your dumb enough 20 years ago to buy the deep ass offset,and you just ordered the correct ones with the folded over rim bead.....a 10 pound sledge hammer works just as well!

https://www.motosport.com/itp-a6-gp-wheel?mmy=honda;trx250x;1991&variant[ITP002M]=ITP002M-X001-Y002

 right now I have 1x4 and the front tire catches everything,I'm ordering 3x2

 

she has a Suzuki 160,I bought it to be my pit bitch at the drag strip,but I also wanted her to try it and see if she likes to ride trails before going out and getting another quad right away.

Edited by Rich1028

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By David Land
      I have an 05 King Quad 700 that has in the past had to have the stator replaced twice.  For the past six months it has been down hard as I cannot get it to fire.  I have replaced the coil (which is the code that came up) and now I have a friend replacing the stator.  I want to see if the new stator does the trick.  Drain the old fuel, and replace with 100% Ethanol free fuel, and see if that does the trick.  The local Suziki dealer will not work on it as it is over 10 years old.  So the nearest dealer is 90 miles away.  The last thing I can do after that (provided the other fixes do not work) is replace the ECM/ECU.  I also read that there was a recall on the ECM/ECU, so I need to check on that.  All of the grounding has been checked, so if anyone has an idea, I would greatly appreciate the insight.
       
      Kindly,
       
      David
    • By BillyBlast01
      My older brother gave me his old 1987 Suzuki LTF 230. It was running back in the summer however it does need some minor work. I have replaced a back rim and put a tube in that tire due to the bead not sealing. New brake shoes for the back needs to be put on and the front brakes don't work. But for some reason it has lost power from the battery. He has a car battery hooked up to it and it cranked over last week but then it stopped and the neutral light was out the headlight stopped working etc. Being disabled and on a fixed income I can't take it to a shop so now I need to troubleshoot. Any suggestions would be great. 
    • By ATVNetwork
      news The KingQuad 500 and 750 Power Steering models get plastic utility rack covers.
      Suzuki says the snug-fitting covers can aid load securing or be a workstation. View the full article
    • By ronald webb
      So where to start my son's LT80 stop running a couple months ago. Naturally I assumed I had a carburetor issues or the peacock valve. After replacing those two items and ensuring I had a spark I started doing my homework thus finding this page. After all the post I have read the next natural thing would be compression I did a compression test today and it was only 60 after spraying WD-40 in it so off comes the cylinder head and The Jug to my surprise the cylinder walls and all the gaskets are pristine so I am totally stumped no idea why I would not have compression when everything looks brand new even the Rings look great any help would be appreciated thanks in advance
    • By JonBat68
      I have a 99 250 Quadrunner. Currently has no spark. It would run for 5 minutes, then shut off. After it cooled down about 20-30 minutes, it would start again. I ordered a new stator and found the old one was damaged (copper windings broken)  I installed the new stator, filled with oil and now it has no spark. Any assistance would be helpful
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...