Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts



Put some darker eyebrows and a mustache on that first one and I think you got it.:wink:

Share this post


Link to post
Share on other sites






Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • By ATVNetwork
      The 34th Annual ATV Dirt Days took place today, August 13, at the historic Loretta Lynn Ranch in Hurricane Mills, Tennessee. This race served as the penultimate round of the 2016 ProX ATV Motocross National Championship (ATVMX) presented by CST Tires, an AMA National Championship.
      View the full article
    • By Scubasonic
      I live in Vancouver Washington but don't have many riding options so I head to Bend Oregon there is a ATV park called East Fort Rock that offers 315 Miles of trails.  I have flexibility to ride during the week (which I prefer) rather then weekends if anyone wants to ride let me know I can be reached at [email protected] it is about a 3hr drive but I don't mind making it as long as the Government Camp pass is not snowing or iced in.
    • By carguydave
      Hello, I have a 1990 Trail Boss 250 that is in very nice shape. I think it has been very well maintained from all indications. The problem I am having is that the four wheeler seems to take an inordinate amount of throttle to make it go. Once rolling, the second I take my thumb off of the throttle it slows down like it has engine breaking instead of just coasting. The brakes aren't binding, as it rolls easily in Neutral. I have changed belts to see if that would help. The belt also seems to have correct deflection. The transmission has the correct fluid, and is full. When I pulled the clutch cover and found a green spring so I replaced it with the blue/green that is recommended. The primary clutch seems to work correctly. I have not watched the secondary. The other thing that I am curious about is that the input shaft seems to be tied directly to the output shaft even in Neutral. If I put the ATV in neutral and rev it up the rear disc spins, which in itself may not be too unusual, but if I pull the brake lever it decreases the rpm like it is putting a load on the engine. So as it sits, it looks like I have an issue with either the secondary clutch or the transmission. My gut says transmission, but I hope not. I would appreciate any insight as to wether this is a normal condition or, if not, how to fix it. Thanks in advance, Dave
    • By Brian Haley
      I wanted to ask this question before I pull this thing apart and dig into the carb. Very seldom used for a couple years but took it out the other day and it ran like crap. Blows black smoke on throttle (unburnt fuel) and sound like a multi cylinder engine with a misfire. Won't rev very high on full throttle but seems to be smooth at about 1/3 or less throttle. Choke doesn't seem to do anything and thinking perhaps it's stuck closed. If I turn off the fuel and let it run for a minute It will rev like normal under full throttle until it stalls out from no fuel but as soon as I open the fuel line again it goes right back to running rich/flooding.
       
      Any help or ideas would be great. Trying to avoid tearing it apart and rebuilding the carb but the only thing I can think is the choke is stuck cause with the fuel off it will rev just fin seemingly as it's emptying the float bowl.
    • By Trish A Hommes
      Hi Im new on here, so please bear wth me, I have a 1994 trail boss 250  we rebuilt the motor , adjusted the carb, and all that good stuff, now it is grinding when trying to get it into gear , reverse works fine, but not forward,idle is good.has no electric start wiring is all messed up.i do need a manual please
  • Recently Browsing   0 members

    No registered users viewing this page.


×