Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I have a 1994 suzuki 300 king quad. It will not fire. On the old plug the spark was jumping around erradically at the end. I tried a new plug and same thing. It is getting good fuel. I tried a little fuel right down the plug hole, but still couldn't get it to fire. Could it be the cdi, or the coil. Any helpful hints would be greatly appreaciated. I am stumped. Can you somehow test cdi boxes.

Share this post


Link to post
Share on other sites


It could be your cdi box causing a misfire. First I thought maybe your regulator/rectifier, but you said you are getting spark, just erratic.

That quad has shifters in the middle, right?

Share this post


Link to post
Share on other sites

There are tests you can do on your ignition components using a multimeter, either buy a manual or contact your local dealer for specs. Check your coil wire and plug cap for damage and a snug fit. You might also want to check your flywheel key, you may just be getting spark at the wrong time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×