quadcrazy

Can-Am - OUTLANDER 800 H.O. EFI

Recommended Posts

Can-Am Outlander 800 H.O. EFI delivers performance features Outlander fans crave, like a suspension using TTI in the back and double A-arm in the front, Visco-Lok auto-locking differential for getting into -

and out of - tough spots and

the SST frame that virtually skis over logs, rocks and other obstacles. And just wait until you hear the purr of the

80-degree V-twin.

Check it out here: http://www.can-am.brp.com/en-CA/Vehicles/Outlander.800/

Bkg_05_Medium.jpg

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  •  Like what you are reading? Please help us by sharing this content.
  • Similar Content

    • By S___S
      On my arctic cat when i put the key in to ignition in turns on the display and then a couple seconds later starts flashing EFI and going from 0 to 110 on the speed odometer. What could be wrong with it ??
    • By Mikes700efi
      Can someone tell me how to remove the rear sifferential. I've got the cv axels out. Do I remove the rear shaft. Or do I pull differential off shaft. Noticed the axel shaft leaking where it go's in the engine. .
    • By Mikes700efi
      I just bought my first arctic cat. I changed the oil and filter. Now my atv smokes only when u rev the engine. Smoke looks white grey.. slight light blue tint.. when it. Idles it doesn't smoke.. Any body have a clue what is going on. The dealer said it's not the rings.. it has the 700cc suzuki engine..
    • By NoviceNorseman
      Hi:
      I am looking for some help. I just bought a 2004 Can Am 400 quad that had sat for 2-3 years. I can start it if I spray some gas into the carb but it only runs a few seconds. I haven't been able to get it to continue. Any advice on what the problem might be and how I might follow it would be very much appreciated. It had about a quart of gas in the gas tank when I got it. I siphoned that out and put in new gas. This is my first quad so I'm quite new to this.
  • Recently Browsing   0 members

    No registered users viewing this page.