Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

yamaharider782

2003 Yamaha Warrior electrical problem

Recommended Posts

Okay so i had a little problem with fuses getting blown and i took the entire harness off and found nothing, checked every single wire and nothing was wrong, then i put it back on and everything was working fine for about 2 months until the other day, i dont think the weather had anything to do with it because i hardly got to ride it and it just quit and keeps blowing fuses, as soon as i get this fixed im selling it. so any ideas guys?

Share this post


Link to post
Share on other sites


Theres obviously a short somewhere but u gotta find it to see where its coming from.......follow all the wires making sure none are stripped or torn

Share this post


Link to post
Share on other sites

Which fuse is it blowing? What circuit?

* Added Manufacturer name into your thread title

Share this post


Link to post
Share on other sites

no the starter doesnt click and its the fuse near the back of the quad twords the battery, i think ive found the problem, the group of wires that has run/start and the lights on it may be the culprit

Share this post


Link to post
Share on other sites


no the starter doesnt click and its the fuse near the back of the quad twords the battery, i think ive found the problem, the group of wires that has run/start and the lights on it may be the culprit

Glad to hear that, keep us posted. I hope that solves your issue.

Share this post


Link to post
Share on other sites

check all connections at the rear of the bike at the main connection going to the brain the brain may be bad inturnally use a freinds and see butt there could be two wires smashed together that you nor anyone else can see alkalene build up can cause this on your connections.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Johnnyhorsepower
      I finally found an awsome app for your phone that shows you on a map all the trails near your location. You can read or add reviews, look at picts...etc
      Its called: atv escape

      John
    • By Steve Howard
      Ran find shut down the quad next day would start and idle when you try to accelerate it would start popping through the carb got a rebuild kit soaked it in chem clean after break down for 12 hours on slow vibrate reassembled and adjusted per manual still the same thing any help would be really appreciated thanks and happy ridding  
    • By dany desbiens
      Hello i have a Polaris 2003 sportsman 600 Polaris Sportsman OEM Gauge Speedo Speedometer Display Dash Cluster 3280425 the speedo is not working no 4*4 i can find nothing can i put a speedo 2004Speedometer Gauge Speedo
      3280431 04-08 Sportsman if it will work
    • By Venom
      Hi All,
      I did a total restoration on a 2003 Yamaha Raptor 80. Rebuilt the engine and tranny.. Started it up today and it runs great. Took it for a ride and the transmission worked perfectly. Adjusted the carb a little more and went for another ride. It ran awesome, pulled into the workshop shifted into neutral ( Neutral light came on) and shut off the bike. went to roll it and noticed she would not roll. Turned on the key and neutral light was on... After some troubleshooting I found that she is in first gear with the neutral light on and will not shift into neutral... It seems to up shift fine into 2nd and 3rd and then back down to 1st. I am hoping somebody can shed some light on what is happening... Thanks for any help...

    • By Colin Davis
      Does anybody know where I can buy a complete wiring harness for a Yamaha bear tracker. If not could someone send me a picture of the the colors of the wires coming out of the cdi plug and voltage rectifier. So I can get an idea of how I need to wire it. Also where can I find a wiring diagram for them?
  • Similar Tagged Content

    • By Chayse Hill
      I have a 2003 LTZ 400 that i bought a few days ago. The quad was running fine until last night. I let my brother ride it down the street and back and i didnt notice anything etong with bike. Then my neighbors friend came over and said "can i ride it?" I said "sure" so he ripped it down the road all fine and when he got back it died right in front of us. My brother said it was dieing on him also. He also said that he wasnt using the clutch to shift. I told him he was an idiot. Im throwing that in there incase that caused a problem as well. But today i go to check it to make sure its getting fuel which it is and replaced the spark plug incase it wasnt getting spark but it is. So i started it and it was having a problem starting then i got started and was reving at idle high. So i took it around the block and it died on me a little bit down, so i try to restart it and it started so i kicked it into 1st and it kinda launched on me and started going with the clutch all the way in. Then it died right after and wasnt running right during that process and was idleing all over the place and just died and now i cant get it started it again. Before it would start without the choke or priming it. It would start real quick now i cant figure if it needs to be rejetted or something else. Air filter looks clean also. But any help would be gratelly appreciated!
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By dyyjrr9
      I just got a 1991 Yamaha Moto 4 for my son and I am looking for a service repair manual. I know that the timing chain needs replaced.
    • By alexcross324
      Hi all, I try to find this manual in the threads but you have a lot of stock here
      Cannot find this particular manual.
      I found it for YFM200 but not sure if they are the same.
      Thanks if you could help me with that.
      Im new here so if I did something wrong, please tell me.
    • By davidwestfall
      looking for direct shift shifting lever that properly fits my 2003 Yamaha warrior 350 and fits my foot the same as a stock 2003 Yamaha warrior 350 shifting lever fits my foot
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...