Quantcast
Jump to content

You guys crack me up sometimes....


Recommended Posts

All I have seen today on the news is how badly the east coast has been beaten up by a 'blizzard.' That blizzard was here a week ago- it didn't even make the news...

Our airports stayed open- we are prepared for this weather- it happens to you folks every year as well and everybody seems surprised.... hmmm

Tip: when you see a storm in the Northwest, start getting ready on the East Coast! :wink:

I still have 18 inches of snow in my front yard...

Link to comment
Share on other sites

It seems like people would eventually get used to the same weather they get season after season. I totally agree, and I blame the media for alot of that. If there isn't someone getting killed or raped, they will try to sensationalize any thing they can, like REGULAR weather. On the other hand, some people are just stupid and no matter how many times they see snow or heavy rain, they freak out. It rains more days than it doesn't here, and traffic still comes to a screaching hault as soon as the first raindrop falls. It's ridiculous.

Link to comment
Share on other sites

This was a Noreaster up the coast that was a product of two storms (one on the west coast), which caused heavy winds and blizzard conditions. It was the windiest storm I have seen in years, a true blizzard. Yes we have had snow storms before, but when NYC gets hit hard..it makes world news.

Took me 3 hours of snow removal today, with my quad and a shovel.

It's still 30 mph winds with clear skies right now, blowing snow.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By DarkRider
      This is something I'm extremely curious about. Has anyone ever attempted to buy a quad (or any other vehicle) from an impound lot? I've always wondered if this could be a bargain, or a waste of time. Google searches do turn up some helpful results. Looks like the state of NJ holds auctions online which I'd be a bit hesitant about.
       
      My online searches haven't really turned up any results of anyone buying an ATV this way. I'd be really curious if anyone tried this, or knows someone who has. I've actually found a couple pages with online auctions for my state, but none had ATVs.
    • By Suzukiquad
      I have a 97 Yamaha Timberwolf and it is beyond loud, is there any good options to silence them or at least make them bare able to drive. I know it has a crack in the exhaust pipe, but even with that fixed its still loud. 
    • By huntindog
      I am in the process of puting it back together after replacing the DPS gearbox.
      The manual I have states that it will need to be flashed by a dealer. Is this still true?
      Also , I have a mystery bolt That I cannot remember where it goes. M6x 70 or so.  Hex head with a flat washer.I will try to attach a pic.
      Pic is no go for now....Cox issue I will try again later
      TIA
    • By vlxerdon
      Hello from southeast Georgia. Was gifted a 2000 Yamaha bear tracker with out a carb or battery and looking like it had seen better days. Was told it had sat for about three years. Explained a lot. Put a carb on and a battery in and it started right up. Surprised the heck out of me  Anyhow as stated in my opening I am  78 years old with a very long motorcycle backgground but brand new to atv's. Anyone else out here from Georgia? Would like to meet up with some folks for a ride or two. Looks like a great site. Thanks for having me. 
      Don
    • By Params_sweden
      Hi!
      I got my KLF300 running again with your help a couple of months ago, at that time it was the ignition coil that had failed. It has been in use since then without issues until two weeks ago.
      When the new issue showed I was going at about 10km/h and it suddenly slowed to a halt. I started it again after that with choke and I drove it 400 meters and parked. Next time it was really hard to start, and since it was low on gas I thought that was the problem. It didn't get any better with a full tank, so I assumed it was the cold weather, and adjusted the pilot slightly.
      After that it I actually got it started again with full choke and some slight gas, I drove about 300 meters and then it slowed down to a halt again. After that, it hasn't started again.
      The compression is 165psi. The spark has good intensity, the ATV has functioned before with the same spark "intensity"/light. I *assume* that it has gas as well, there is definitely gas on the spark plug when I remove it
      I have checked the carburetor slightly, the float works, diaphragm looks ok, but I haven't disassembled it to really look for dust and such in all the small places.
      My theory right now is that it might've been some dust in the gas tank that went into the system, it's just a theory
      I'm thankful for all the help and pointers I can get, don't hesitate

      / Pär, Sweden

×
×
  • Create New...