Quantcast
Jump to content

does back fireing damage my quad?


Recommended Posts

The carb should have o-ring gaskets, they are fine to re use as long as they are not brittle or damaged. The backfire itself will not likely damage anything, but the condition that is causing it could. I would start my checking the carb, air filter and valve adjustment.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By JonnyBlaze
      I need to diagnose / replace switch on my Big Bear. It's been intermediate over last few years and finally quit. Nuetral light doesn't come on and have to pull brake in to start. 

    • By huntindog
      I am in the process of puting it back together after replacing the DPS gearbox.
      The manual I have states that it will need to be flashed by a dealer. Is this still true?
      Also , I have a mystery bolt That I cannot remember where it goes. M6x 70 or so.  Hex head with a flat washer.I will try to attach a pic.
      Pic is no go for now....Cox issue I will try again later
      TIA
    • By lester
      I picked up a 2000 Big Bear 400 4X4 that was sitting around that I know nothing about. It will not start. I do have a red light when in reverse. When I take it out of reverse, I do not get a green neutral light, and when I push the start button the red oil light comes on but there are no noises, nothing else happens. How do I test the neutral switch and/or bypass it to see if I can get it to at least crank? And does anyone have other suggestions for me to try?
    • By Need-help-with-quads
      So I have an 89 Yamaha moto 4 250cc and when I ride it, itll get hot after like 10-15 mins and then will just die and turn off.
      It's has new carb rebuild, new air filter, new battery, new spark plug so I don't think it's a crack in the spark plug
      Can anyone help me?
    • By ResQ91
      Hi guys
      My 87 Bear 350 won't start and could use a hand.
      Turn key on and Oil light turns on and then slowly fades out. (I think this is key to this) No start, not even a tick.
      battery and connections good
      A Solenoid post jump turns it over
      Neutral Safety Switch wire attached and seems good
      It has not had a wire/switch on Rear Brake Pedal ever since I had it.
      Any thoughts on some other things to troubleshoot this??
×
×
  • Create New...