Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Dennisg

1989 Suzuki Quadrunner Carb trouble

Recommended Posts



I got the float in right this time. But it may need adjustment?

It still runs fast with no adjustment in the idle adjustment or in rich or lean.

Any suggestions on what to do now?

thanks

dennisg

Share this post


Link to post
Share on other sites


1989 Suzuki Quadrunner.

I got the top end overhauled and putting it back together now.It ran good just smoked.Now it does almost the same thing. Excessive smoking and idling to fast with no adjustment on the screws. I am certain it is a carburetor problem but how to fix it is another problem.

Thanks

dennisg

Share this post


Link to post
Share on other sites

Sounds like its not jetted properly, correct size....was it ever changed?

* Added year, make, and model to thread title.

Share this post


Link to post
Share on other sites

I have completed the carb rebuild and the engine runs and smokes just like before with no change except that it runs and starts better. It idles fast and cannot be changed by messing with the 2 screws on the carb. Why does it still smoke and why will it not adjust the idle?

Thanks

dennisg

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Jodawg1981
      How do i find out what carb came on a 06 suzuki ozark 250? Trying to get a new carb and need to know the model number or size. I know its a mikuni. Or if anyone has one let me know
    • By M C
      Hello all!
      A friend of mine has this particular 4 wheeler. It sat in the garage for about a year, so I redid the carb, cleaned the tank and installed a new petcock. So far, it cranks right away whether its button started or pull started. So I have a couple of questions concerning the carb and air filter.
      1. Is this a cvk32 250 or 350 carb? As the air fuel ratio adjustment is different according to a cvk document I read. What's your adjustment setting? 2 whole turns and a 1/8 or 2 whole turns and a 1/2? Comparing the old setting on the carb to the new setting (and where the needle sits now), makes me think it was way off before. 
      2. The Air filter cover, gasket, air filter and plate element are all missing. So I was thinking of removing the hose that goes to the air box and put one of those K&N style looking filters and be done with it. So my question is.. will I have to readjust Air Fuel screw or just adjust Idle?
      It's just going to be driven around the neighborhood.
      Thanks in advance for any info or help. Y'all stay safe out there!
    • By basmn
      A friend has a 07 trx 400ex..the engine drain bolt housing has a couple of cracks where the drain bolt threads in and is leaking oil...a one had any luck sealing this area with JB weld or something similar ?
  • Similar Tagged Content

    • By Aj Hurtibise
      Hey guys I'm new to the Forum I just got a 2000 Honda trx90 looking to make it go a little bit quicker I don't know much about four wheelers but I am a technician at a dealership so I know my way around a motor.
    • By Ellery Zandt
      I have no idea where the antifreeze line coming off the thermostat goes too. The carb two nipples in the pic create a vacumme. Can someone help me on this please....!!! my email direct is [email protected]!!!!
    • By Ellery Zandt
      Does anyone have a redcat 250 or falcon 250cc that they can share where the two vacuum lines on the carburetor that you run antifreeze through I honestly have no idea where the lines are suppose to go to circulate the antifreeze. 
       
      Any help is greatly appreciated. 
       
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By Tubecatgs
      A friend of mine has this Bayou 220 that started running bad and parked it a few years ago. I foolishly volunteered to take a look at it. I noticed right away the choke plunger on the carb was broken and probably the reason it was running bad but now the old gas was evaporated and like turpentine. Before i even tried to start it, i drained/ thoroughly washed the tank out, new fuel filter, new fuel lines. Blew air through the petcock etc. Changed the oil and filter and air filter and new choke plunger and cable. I disassembled the carb and rebuilt it with a kit. I cleaned the main jet with solvent and poked a wire through it to make sure it is clean.. the engine now fires right up with the choke on and dies when i take the choke off. I adjusted the air/fuel screw to about 1.5 turns out and the idle screw about 2.5 turns out. The rubber boot between the carb and head does not have any cracks in it so I don't think it is leaking air. I originally had the clip on the needle on the second from the top ring... when i moved it all the way to the bottom it starts, runs and idles really fast and will idle eeally high with the choke off but if i adjust the throttle cable and/or idle screw to a slower idle it will sometimes stall but the idle will go up and down every few seconds and when you give it gas there is a hesitation... i tried moving the clip down to rhe second from bottom and same problem... i replaced all the parts in the pic to the top right. However, there appears to be a small o ring, washer and spring left over from the kit... i did not see these get removed..... a) any idea if where these extra parts go and if i need them and b) any other ideas on why i cant get it to idle right or carb adjustment ideas?
      Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...