Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

deerjohn

1997 Polaris Trail Boss - Runs With Choke Only?

Recommended Posts

My 1987 Trail boss will start with choke on, and then the choke must immediately be taken off to get the engine to run for 5 seconds only. If the choke is reapplyed when the engine is shutting down after burning its 5 second gulp of fuel from the choke, it will run for another 5 seconds and so on. I have removed and cleaned the carb twice without finding a problem or improving the problem. Each time I remove the carb, the bowl is full of fuel. Compression is 95 psi. It is only running on the fuel provided by continually applying the choke!! HELP!!!!!!!!!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites


Guest kjames

Just curious, what did you find out?

Share this post


Link to post
Share on other sites

I think the rubber carb adapter between the carb and the cylinder may have had a crack in it! After taking the carb on and off three times, I noticed the adapter was actually ripping apart. I just got a new adapter Friday, but haven't installed it or tested it. I'll let you know. I hope the adapter resolves the problem. John

Share this post


Link to post
Share on other sites

I've installed the rubber adapter, and it runs and idles without the choke!! I'm heading north with it for the holidays and will give it a good workout. We have 5 quads up north, and they drive me nuts keeping them all running right. I'll let you know if the adapter was the fix. John

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Steven Urban
      First time using this forum.  Owned a Kawasaki dirt bike once, had no issues.  But I picked up this 4 wheeler at an auction.  They stated it ran, but only needed a battery.  Well I do not believe that was all true.

      Some pictures are attached.  Not sure why, but the whole air filter stuff was removed.  They had some small thing inserted as a make shift air filter.

      I purchased a battery to try this all out.  Waiting to return it and get the proper size, as it was too big for the battery box.  But here is my issue I had while the battery was connected.

      1 - The lights on the steering column did not come on.  Not sure if they work or not.

      2 - The starter solenoid seems to be bad.  I have a new one on order. 

      3 - In the pick, there is another rusted part.  Not sure what that part is or what it is used for.

      4 - What is the 12v rectifier?  square bodied part.

      So when I hooked the battery up.  Pushing the start button did nothing.  Pulling the cord to try and pull start, it turned, but would never fire.  I have put in a new spark plug as well, it looked worn out.  With electric start, I crossed over the posts on the start solenoid, it turned over, but would never fire and start.

      I have read a few other threads and it stated something about needed the neutral light on.  SOmething about a kill switch.

      Any help would be appreciated.



    • By Rigo Mena
      I have a Kawasaki bayou 220 that won’t start I don’t know if it has something to do with the electrical wires but when I put the screwdriver on both bolts of the relay it wants to crank but can’t and there’s a missing piece I think it’s another relay that has 6 wires going into it
    • By JacobSlabach
      i know this isnt an atv but same type of thing.  I have a riding mower im fixing and selling for my aunt and it has a dead battery.  i jumped it off my atv and when i turn the key nothing at all happens.  i tried jumping the relay still nothing.  this is with the seat down.  you wouldnt think this mower would have issues as its a top-of-the-line brand and almost brand new (aunt found it for a good price, still got tits on tires, just sat for a couple months in a mechanic shop
    • By dave3dracing
      Hi, I'm a new member
      Just bought a used 08 350 raptor with about 5 hours on it ( very clean ). Started fine when we got it. Now after a few mods (bumper, skid plates, air filter) Now will not start unless you pull in the clutch. I've checked just about everything and also checked that there is no pinched wires. Anybody have any ideas?:bangheadc: Thanks, Dave
  • Similar Tagged Content

    • By Sniderman
      Does any one have this manual?
      93 trail boss 350 2x4
      Thanx
    • By RoxanneRoseReid
      Need a polaris manual for a 1994 2 stroke 2/4x4 quad free. can you please post a link I can click on Thank you. Roxanne
    • By buzzar56
      I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace
      thanks fred.
    • By Weldingrod47
      Trying to change front wheel bearings. I removed the cotter pin and castle nut. Hub won't budge. Is there an additional retaining clip? Seems to be one of those push on type that barbs on the thread of the spindle. How do I remove it?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...