Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Hi i am new here and wanted to introduce myself my name is Frank and go by the username(Polarbear),i am from Brussels a small village in southwestern Ontario,Canada,36 years old no wife ,no kids,just a couple of yamaha grizzlys and plenty of time to ride.

Share this post


Link to post
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By fox300exchic
      Let's hear all there is to know about you ladies! Where your from and where you've lived. Kids or no kids. What you do for a living. Why you ride and how you got started.
  • Similar Topics

    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By mike91
      I’m just wondering what year bike i got? it seems the vin has been rubbed off i got it from a auction here in Australia engine starts but seems has a dirty carb wont idle well
      and also has a problem I put it in gear and makes a grinding noise but does not move it the neutral light goes out but then when I change gear it grinds more in the higher gears as well I’m guessing the differential is stuffed so wanting to buy new part for it will start the pull down next week

      this is the first bike I have worked on used to dealing with cars




    • By Randel1
      I'm having a problem getting a CDI unit that works. The parts list calls for a  4XE-85540-00-00 CDI unit. The one currently on the ATV works but there seems to be a problem with the spark advance curve. It will idle fine an rev. to about 1.5K then  starts bogging down sputtering, popping and basically running poorly. If you can get it above 2200 RPM it runs better. I have ordered and returned about 5 replacement modules that will not work at all. The unit currently on the bike has no part numbers or identification other than a Mitisibuchi logo. I am wondering if anyone else has experienced similar problems with replacement CDI's and if so what is the fix? So far I have not found a replacement CDI that will supply an pulse to the Ignition coil.
    • By matw
      At a loss...
      Runs/starts great when jumped across solenoid. Solenoid has been replaced. Battery has been tested and is good. Doesnt start with start button but starter will engage when machine is running if button is pushed. Machine also is not charging.  Regulator has been replaced. Stator has been tested and passes all 3 phases voltage and open to ground all 3 phases.  Lights work great with machine running and battery disconnected. Starter solenoid relay has been replaced.
      Any help or suggestion much appreciated. I do not have a wiring diagram or manual which i probably should try and get.
      Thanks
    • By jolio
      Just got a '98 Yamaha big bear 4x4 in working condition (so far). Looking forward for some good information on this site about how to keep it alive.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...