Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

hangingon

Got my quad starting with the old battery

Recommended Posts

Heres one for all you poor folks like me. My battery got to where it wouldn't take a charge or start my quad. I read a blog on using Alum from McCormick for pickling. Alum & distilled water is all it takes besides cleaning out the old acid with baking soda and water. I can't belive it worked but it did. It took adding a little more alum till I got the mix right so far I've made about seven starts.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Bobby_Rickard
      Replaced battery, relay and starter. Turns over and starts part of the time and other times just rapid clicking. 
      IMG_2753.MOV
    • By mjm4jc
      Hello everyone,
      My Suzuki LT185 didn't come with a battery from the factory (no electric start). I was wondering if I would need to add a battery if I wanted to install some of those light bars/pods or should I just wire it in to the headlight switch? Will the generator be able to put out enough juice to run the light bar? Also, is it normal for the headlight to get dim at idle, then brighter when driving? Never had a quad before with just a generator. 
      Thanks!
    • By Gilbey
      Hey yo quadsters, I have a question regarding CCA in batteries. My ATV is cold natured and it will start with my generic battery that's in it, (don't ask me now what battery I have in it cuz I'm at work,) but when I hook up an external battery storage unit (Beatit 1200Amps QDSP 1200A Peak 16500mAh 12V Portable Car Lithium Jump Starter) for quick jumps it fires so much faster.  Which by the way is a bad ass accessory to have around. I keep the battery in the quad fully charged all the time. My question to the pros is how much difference does the CCA of a battery contribute to the quicker start?  
    • By Tim Orr
      Installed new battery was told that’s what was wrong when hit start button I hear 1 click then nothing?  Can the battery just not have enough amps to crank the starter the first time ? I trickle charged it overnight thought it was enough!
    • By Ajmboy
      With this cold snap, I noticed yesterday that the battery on my grizzly was a little weak. even clicked a few times before I got it to start. I'm thinking of picking up a batter tender/ trickle charger so was wondering what people use to keep their ATV battery charged up. I was looking at these on amazon. They both have good reviews.

       
      or this one

       
      Kind of like this one because if the accessory plug

  • Similar Topics

    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By Brennon Heflin
      So I bought a 2000 quad runner 250. I'm having some issues an wondering what it could be I replaced the pet cock valve an the fuel filter an pump inside tank I also put a voltage regulator on it. The problem I'm having is that when u give it half or more throttle it bogs down an loses power what could it be the bike is almost like new an cant figure it out any help would be great
    • By NoahJakavi
      Hello i have a linhai 300 of the 2004+- era. I had a cluch problem so we changed it. After changing it has a hard time to start going. When you pop it into gear and press the gas it barely drives but when it starts going about 20km/h it start driving well the acceleration is normal and everything do you have any idea of what could be the problem
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...