Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Whip

94 Suzuki LT-F250 Quad Runner Carb Diaphragm

Recommended Posts

I am trying to locate 1994 Suzuki LT-F250 Quad Runner Carb Slider Diaphragm I only need the Diaphragm not the slider. I have tried to find a part number for the Diaphragm but have failed to find one. I have found a Diaphragm on EBay but the model years don't match. I sure would appreciate any help anyone can provide.

Share this post


Link to post
Share on other sites


I am trying to locate 1994 Suzuki LT-F250 Quad Runner Carb Slider Diaphragm I only need the Diaphragm not the slider. I have tried to find a part number for the Diaphragm but have failed to find one. I have found a Diaphragm on EBay but the model years don't match. I sure would appreciate any help anyone can provide.

Look at the repair manual. I believe model years '90 through '98 were identical/interchangeable.

Share this post


Link to post
Share on other sites

Have you looked at the part finder on Bike Bandit or other sites to see if you can just get that part?

Sent from my iPhone using Tapatalk 2

Share this post


Link to post
Share on other sites

Thanks for the replies I didn't get any email notifications from quadcrazy in regard to this post.

Thanks Nor7 and Ajmboy, for trying to help me out!

Tonight I went ahead and placed an order for the diaphragm with slide included and a rebuild kit from Jets R Us the total came out to around $115.00.

I looked everywhere for just the diaphragm only but could not find one for the 94 model. I found some for newer models though but wasn't willing to gamble on getting something that may not work.

Thanks and God Bless, Whip

Share this post


Link to post
Share on other sites

Update On My Parts and Rebuild!

In my last post I mentioned having placed an order from jetsrus.con for a diaphragm with slide included and a rebuild kit however after waiting for almost two weeks I never got my order so I finally emailed them only to find that the diaphragm with slide included was on back order.

Well I requested my money back and once I got that back I ordered a OEM diaphragm with slide included and a Aftermarket moose carb rebuild kit from bikebandit.com which the total was around $163.00.

I got my parts in less than a week then cleaned the carb and installed the new parts and it is working like a new one.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Guythis448
      Looking for help on wiring up stock wiring harness specifically for a '88 Honda TRX 300 
      If anyone could drop a link or send me a PM it would be much appreciated 
    • By Reece K.
      I just recently bought a 1994 Yamaha Timberwolf 4x4 from a buddy who had the wheeler sitting in his garage for 7 years. I got it home and fired it up pushed it out of the garage and tried to shift it and it wouldn't shift. First it would click like it was shifting, but the wheeler wouldn't move and when I hit the gas it revved up like I was in nuetral. After trying some more it became stuck in 1st gear and wouldnt shift at all. But it later broke loose agian and acts like it is in neutral again. I took the motor off the machine to make it easier to work on.After asking friends they were convinced it was a clutch problem but after opening up the casing for the clutch I don't see anything out of the ordinary and am concerned that it may be a transmission problem. Any help would be greatly appreciated thank you.
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
  • Similar Topics

    • By AKMichael
      Hello All,
      I have a 1999 Yamaha Big Bear 350 4x4 trying to get fixed up so my grandson can go out in the woods with me.
      We have owned it over 10 years.  It got harder to start, until it finally would not.  Replaced the carb.  Right afterwards, it started and ran nicely, but after turning it off, would not restart.  Tonight I used starting fluid and ran, then died.  Adjusted the idle up a little, used more starting fluid and ran great.  It idled about 15 minutes.  Turned it off, and restarted.  Ran it around the yard about 5 minutes.  Turned it off, and would not restart.
      Any ideas or suggestions would be greatly appreciated!
      Thank you. 
    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By Brennon Heflin
      So I bought a 2000 quad runner 250. I'm having some issues an wondering what it could be I replaced the pet cock valve an the fuel filter an pump inside tank I also put a voltage regulator on it. The problem I'm having is that when u give it half or more throttle it bogs down an loses power what could it be the bike is almost like new an cant figure it out any help would be great
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...