Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

Ignition Fuse Keeps Popping


Uwood

Recommended Posts

Please help if anyone has any idea why ? I have a 2008 Suzuki king quad ltf400f & it keeps blowing my ignishion fuse I have unplugged all the connections in the front besides the ignishion & soon as I turn the key on it pops I I have traced it to orange wire from there & I

Don't have my cci hooked up I tried unplugging voltage reg extra ??? I did take my starter neutral relay apart & it did have broken inside & with that out it still pops it ? Wood that pop it even out ? & a few times I had thought I had it & went to start it & soon as I pulled or used electric start pop ? I am wiped I dunno what to do any help wood be really really really :-)

Thanks

Link to comment
Share on other sites

Woo hoo so I don't no why or what but tonight working on it it magicly stopped poping fuse

& ran for first time in 6 weeks :-) I don't no what happend tho all I no is my starter relay is no good as my starter isn't working but it ran from the pull start & the only thing I did els tonight was un hook all the stuff from orange & whit wire ? & slowly hooked em all back & watched as the fuse didn't blo oh & I put the tail light fuse back in as that wire lead there ???? Well tomarow the big test as I put it all back together & try it

:-o all let you no :)wish me luck !!!! Da misery mystery

Link to comment
Share on other sites

Ok so I took it out was good for a hr then poped ! But unlike before it did not pop right away when I put a new on in but riding a few km later ? So after this for 4 fuses I put my spare 30 amp fuse in & made it home no more fuses ? What wood couse this ? I do no it's not good to do & stuff & to all you that no how much of a pain it is to get at it ? Stupid plastic lol anyway if it's a short in the wire wood the 30 amp fuse not of blown ?????

Link to comment
Share on other sites

Sounds like a game of chance finding the short. Try pulling the fuse & hooking up a 9 volt dummy light to the dead side of the fuseblock & the frame. Then start jiggling wires, when the light keeps flickering on & off youre getting close. Definately sounds like a chaffed wire to me. You unfortunately will probably need to be taking off some of the plastics. Focus on the steering shaft area,dash and any othe places moving parts could rub thru wiring. Especially look behind tie straps where the harness is attatched to a frame member or metal brackets. Good luck. Youll be ecstatic when you find a bare wire. :-) Also, make sure the ignition switch itself isnt bad & shorting out internally. ( unplug it while doing the test.) Do you have a heavy keychain hanging off the key?, just a thought.

Edited by Mudflap64
added content
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By GrizzlyRider
      The 2024 ATVs are out and I was just looking at the websites for Yamaha and Suzuki. The Grizzly and King Quad have come a long way, probably two of my favorite quads over the years. Both of these come with power steering but I almost like the King Quad styling a little more. The plastics haven't changed much over the years either, mayeb a little more rugged. The King Quad racks are more like the Polaris plastic racks (I think they were the first to introduce these) but on a closer look, I think its just plastic covers over the traditional metal racks. The Grizzly still keeps the old style metal racks. I like the display/instrument panel on the Grizzly more.
      2024 Suzuki King Quad


      2024 Yamaha Grizzly

      Thoughts on these two? Here's a pretty good comparison of both 2023 models. I didn't know some of these things like no seat latch on the Grizzly and hydraulic rear brake vs cable. Good video to watch if you are consideting these:
      Grizzly 700 vs KingQuad 750! 2023 Full Shootout!" width="200">  
    • By p5200
      I added more fresh gas it sat one day now, it's acting up again. Before cleaning out carburetor it wouldn't idle good and had gas leaks from carburetor. Now it idles pretty good but, if I increase throttle speed at a certain amount it starts missing bad. I'm going to try and post a short video. Just about ready to give up on this thing.😒  you can see reflection perking in video.

      20240217_114429.mp4
    • By Mhatayas
      What should I do about this , bad oil leak where the filter cover bolts on . Can I use some gasket maker 

    • By Traytonrowland
      So, I bought the machine almost a year ago and have been chasing problems. I have replaced the battery, starter solenoid, spark plug, and the starter. Since having replaced those, it doesn't want to start. I checked the carb, and it was wet as well as the spark plug. And I've searched multiple forums and cannot find an answer. So, anything that helps is appreciated, thanks. 
    • ATV Service Manuals
    • By Lukequinn
      I have a Yamaha beartracker 250 that I can’t seem to get running right
      i am after replacing the spark plug, carburettor, and the carb boot to the engine when she starts she revs up like mad  even when the mixture screw on the carb is fully in when running she pops and stalls and won’t rev up 
      has anybody have any idea what could be wrong with it thanks
  • Similar Tagged Forum Content

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...