Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

1987 Yamaha Warrior 350 - Hard To Start


en4239

Recommended Posts

my 87 warrior 350 wont start most of the time. it cranks just fine, has a new battery. its getting fuel, and when I have the air tubing off I can see the first jet (by throttle plate) squirting fuel. it doesn't seem to get a spark or the one it has is very weak when using my spark tester. I tried a new ignition coil, wire and cap and no difference. tried cleaning the carburetor (wasn't dirty) and no difference. it will randomly start sometimes and runs great when it does. and will start again a few times right after running. but once it sits for about 20 minutes it wont start again. ive been beating my head over this one and last resort is pay someone else to fix it. I have a feeling it may be the cdi unit or maybe something to do with the stator or pickup coil but don't know how to troubleshoot em and don't know anyone with the same bike to try their parts. any help is appreciated

Link to comment
Share on other sites

  • 2 weeks later...

been a while but finally got an update. still hasn't solved my problem :aargh:

got a stator from rmstator off ebay. saw some people say rmstator was a very good brand so I went with that. put it in and still has trouble starting. but I have got a few new symptoms.

Part 1: when it is about to start the starter makes a weird noise that its never made before almost sounds like its binding but then it starts right up. whenever it doesn't start and just turns over, it sounds like it always has before and once again its got either no spark or a very very weak spark. soooo think maybe there is something going on with the starter? cause I don't know

Part 2: when it is running, it seems like it misfires at random a few times, doesn't run smooth like it used to before. and it smokes when accelerating but not at idle. now besides putting in a new stator I did an oil change since I knew I was going to lose some oil. I wasn't sure what grade oil to put in it so when I was buying the filter from the store I asked the guy what grade it should take. he said 20w-50 since I don't run it in temps below 40f. and I bought the good yamalube oil for four stroke motors. 20w-50 seems a little thick to me but I took his word for it since he knew about them more than me (or so I think). this is my first time doing an oil change on it since I bought it last year, so I don't know what grade oil was in it before. is it possible the oil could be affecting something?

just some thoughts and problems I have with it, any help or comments are appreciated

Link to comment
Share on other sites

  • 3 weeks later...

so after banging my head on it for hours I gave in and took it to my quad guy. he spent a few hours on it and found out that the ignition switch was dirty inside and needed to be cleaned. who would've thought that was the problem. it turned on all the lights just fine and it cranked over so I never thought that there was more to it than that. so glad this chapter of the quad is over with

Link to comment
Share on other sites

so after banging my head on it for hours I gave in and took it to my quad guy. he spent a few hours on it and found out that the ignition switch was dirty inside and needed to be cleaned. who would've thought that was the problem. it turned on all the lights just fine and it cranked over so I never thought that there was more to it than that. so glad this chapter of the quad is over with

That is not something I would have thought of. I just had mine at my mechanic. It was the pickup and stator like I thought, but he had a heated garage and a lot better tools and knowledge than I do. I have single digit temps today yet, but up to 48 on Saturday. :biggrin: . The best part is I have a quad that runs.:laugh:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By jashadams
      Hey all back again with my 1989 moto 4 250.
      After putting a new carb on it it's really sputtery, it has new gas and I'm wondering what to tune on the carb to make it idle better. I've attached a video to describe the issue more. The bike is still work in progress but I think the video gets the point across. Thanks!
      Snapchat-1142015191.mp4
    • By Grizz10
      Hi all,Grizz 350 4x4 irs owner here, saying hi
    • By Gwbarm
      My Yamaha Big Bear shifts through all the gears good, goes into reverse smoothly, but when i go to get out of reverse it takes a lot of effort to get it back to first gear, and even then it does not go very smoothly, have to pull up on the pedal really hard, anyone else ever had this problem. Any ideas would be greatly appreciated.    
    • By Mikey69
      Heres my story. Kinda long. I guess I was a late bloomer when it comes to quads. I had never ridden a quad in my life. Rode Dirt Bikes as a kid growing up. Back in Oct of '06 I found a Mustang on craigslist. Took it for a test drive one morning before work. Fast car. 351 Cleveland. I had planned on meeting the guy again after work. For some strange reason thats still to this day beyond me, I stopped in Hillsboro MotoSports on the way home from work. I had 6 Grand on me. There was a left over '05 sitting by the front door. It was on sale for $4999. It was $5499 OTD. I didnt even look at anything else. I knew nothing about quads accept I thought it really looked coool and I had the money in my pocket to buy it. I was sitting on it when the salesman walked up and asked... "Can I help you?" Without hestitation I pulled 60 Ben Franklins outta my front pocket and said "I want this Quad. Load it up in my truck." It was just about dark by the time I drove away from the shop. BTW, I didnt bother to ask my ol lady if I could buy it. LOL. Anyway, I took it by the house and showed her. She was kinda stunned but not mad. We drove over to a friend of mines house and unloaded it. I took it to the field across the street from his house. HOLY CHIT!!!!! I was surprised by the power. I had it for about 2 weeks and took it to Sand Lake. I was there a few hours and rolled it on a banked turn at the top of the bowl right before you get to the one-ways. When it rolled, I flew off and landed on my belly. The quad came bouncing and landed on my back. For a month I couldnt even walk. I was scared of it. I considered trading it for a 250EX. Went back to the shop. The salesman said..."Dude!!! You dont want a 250EX!!! Trust me. Just get used to it" I still wasnt convinced. I put it on craigslist for $4000. Calls were coming in. I had a guy that wanted to come look at it that evening. I decided to take it for one last ride at Browns Camp before I sold it. I was still afraid of it. After about 5 minutes I started feeling comfortable on it again. I decided right then, I loved my Honda 450 and would learn how to ride it instead of selling it. That was late Nov of '06. Work was slow for a Painter in Oregon. My new job everyday? Going to Browns Camp and ridding my Quad. I bought my Girl Friend an '02 Blaster. I rode my 450 for 4-6 hours almost every single day for 3 months. And yes, I know my way around Browns Camp pretty well. LOL. In March I bought her an '06 TRX250EX (Thank God I didnt trade my 450 for one of those) LOL Since then, I have become totally addicted to quads. I love them. Couldnt imagine not owning at least one quad. Luckily I have two. My "07 was $6500 OTD in July of '07. Bought it for my Girlfriend. Traded in her 250 EX. A month later we broke up. So, I wound up with two Honda 450's.
       
    • By Fish0rDie
      Well yall, it's been a while. Work has absolutely annihilated me for the past 5-6 months, and ive had bare minimum time to work on this project. Thank you to those that helped previously during the engine rebuild, but now were on to the task of wiring, and let me tell you besides the plugs on the wiring, I am almost completely lost. Bought an ebay harness, and none of the colors line up to what i have seen on any manuals. Its all the 97-01 electronics i believe. Ill post some pictures below of the mess I'm working with. Emphasis on "mess." A lot of the wires had to be extended since the harness was made for an atv and not a buggy. The colors are a little wonky, but I was using what I had, and they were mostly for just extending the plugs, so the colors match on either end. A buddy of mine has been helping me, and we are just at a loss. Looking for general guidance or any wire specific help you could give us. Not even sure if some of the single wires are plugged in right, and we dont have a "lever switch" wondering if thats just for the brake, because the master cylinder has two screws. I suppose a + and -... We also have what I believe are the reverse and neutral sensors to plug in (the only two sensors on the engine)
      P.S. peep the custom airbox i 3d printed to utilize a lawn mower filter and 2x2 coupling from lowes 
      If you need better pictures of anything, let me know, It's kind of hard to get pictures of this rats nest.
      Wires that are not connected to anything
      4th picture black wire
      5th picture blue wire w white stripe left/solid blue on right
      6th picture what I believe to be the lever switch from pictures I saw on ebay
      7th picture is two black wires coming out of the harness. One we have running back to a black with white stripe that comes out of a different place in the harness. The other that had an end to match the single wire coming from the handle bar switch. Single handle bar wire has a white stripe, so I may try to switch those around if the ends permit it.
      I know it just looks god awful, but i really do think we are close, and the idea is to figure out whats going where, then figure out how to make it look better, so bear with me haha. Any help is appreciated. Just finished a little go kart for my wife with a predator 212, and gosh do I envy that wiring (there is none😂)
       












  • Similar Tagged Forum Content

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...