Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2000 Arctic Cat 300 - Firing Problem


Bigdaddybruce
 Share

Recommended Posts

hello folks, thanks for letting me join your forum. I have a question I hope someone can provide an answer to I have a 2000 model Arctic Cat 300that has a firing problem. The spark plug will get fire to it as long as you hold down the starter button, but as soon as the starter button is released, there is no more fire at the spark plug will I get lucky and possibly have just been a glitch in switch problem,or is this more likely to be a c_d_i problem? any suggestions would be much appreciated. Thank you in advance

Edited by Bigdaddybruce
misspelling
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...