ukinfla

2007 Suzuki King Quad 700 problem

2 posts in this topic

I have a 2007 Suzuki King Quad that I bought new. Minus battery problems, I have had no problem with the bike until now. I changed the oil and had a problem with the filter I didnt know about until it ran out of oil. Engine shut down. Towed back to camp where problem was diagnosed. Fixed oil filter and installed new oil. Bike will not start, although it seems to want to. No warnings on the LED display...any suggestions??? Thanks in advance!

Share this post


Link to post
Share on other sites


Try disconnecting the batter to reset the computer, that's fuel injected I believe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
    • By evlsnke
      loud clicking, snapping noise under load when accelerating.
    • By superdude811
      Can you put tracks on manual atvs? would it be effective? is 280cc enough to even move them? thoughts/suggestions?