Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

1999 polaris 500 sportsman grinding in 4 wheel drive ?


oldcomet
 Share

Recommended Posts

Morning Folks

Ok so I have taken the front hubs apart everything is good and working fluids changed and full In 2 wheel drive the bike works great However in 4 wheel drive high I get a grinding clunking noise right near the foot pegs The universals are all brand new in the complete bike The problem just started after my last ride Sometimes I have to change the rpm to get the bike to go into gear in forward and reverse The bike doesn't make the grinding noise when I have the bike in 4 wheel driver low gear only in high gear Could the shifter need adjusting any help would be great Thanks for your time

Oldcomet

Link to comment
Share on other sites

Dream Car Giveaway

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...