Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

1998 Suzuki King Quad Red hot exhaust


Recommended Posts

  • Admin changed the title to 1998 Suzuki King Quad Red hot exhaust


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By PGregory
      1700 miles on the machine, all trail riding.   Second ride of the day and I get an overhead light, shut it down, let fan run, fan shuts off, light still on, ride back to camp, clean radiator, let machine cool for a couple hours.  Start up, head over to the campgrounds, ride for 5 minutes or less, overheat light comes back on and the machine blows the ignition fuse.  Tow it back, replace fuse, turn on key, fuse blows immediately.  I've ran all the wires, no mouse chews or rubbing, etc.     Does the KingQuad have a thermal protection system that would explain this?   
    • By Quad king
      I am not sure what is wrong with my King Quad. I had a new carburetor put in 6 months ago, just replaced the fuel pump and added an in-line fuel filter in. I have been trying to fix this quad for a while now and do not know what is wrong with it. It idles fine and runs great as soon as it is fired up, you can Rev it and stay in first gear with 100% power. As soon as I drive 10 feet it looses all power, I mean it is sputtering and doesn't move at all, but when I let off the gas after it sputters it idles fine. I will attach a video of what it is doing.
      Snapchat-1290161440.mp4
    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
  • Similar Topics

    • By Andy7734
      Picked up a 89 moto 4 250 for cheap a few years back from a friend that was moving.   It ran and drove then, but wouldn't idle without quitting.  Anyway, I pulled it out recently after it has been sitting to see if it would start with a new battery.  It cranks but won't run.  Fuel is getting to the carb from the fuel tank and I have good spark.  If I pull the plug and pour a little gas in and replace the plug, it will run for a few seconds and quit.  I figured it has to be carb related so I pulled the carb and have been inspecting it.  There is some gunk in the bowl.  The big jet looks ok, but I think the small one is completely clogged.  I am guessing this would be enough for it not to start, correct?  Am I on the right track?  I like to dig into this kind of stuff but don't have much experience with small motors.  Any suggestions would be appreciated.   I did order a carb rebuild kit on ebay with new seals and rings for putting it back together too.
    • By BOHUNTER
      Hi  all, I have just come into possession of a 85 lt230 shaft drive but I cannot find any clutch adjuster on it anywhere....
      Can someone help me out here or do I have to replace the clutch...
      Tia
    • By doublee
      Hi,
      Im replacing head gasket on my 350L because it started leaking water and i think the previous owner did not use correct torque.
      I dont have the service manual so do anyone know what torque to use, anyone know?
    • By rolorox
      I got a 1996 300 king quad 4x4 wondering if a 1998 500 king quad engine will fit and will it hook up to the 300 transmission thanx
    • By jwrjr73
      Hello all I have a 1998 Quadrunner 250 4x4 
      I'm having problems with it going into high low and won't go into Diff lock..sometimes reverse seems stuck too..I even have were the green neutral light will be on sometimes with the red reverse. After driving it and then stopping it won't start back up until I mess with the reverse shifter. Any help would be appreciated..
      Thanks 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...