Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

ATVNetwork

6 Scary Good Halloween Deals For Your ATV Lifestyle

Recommended Posts


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By BuckBilly
      I like to ride in wooded and grassy areas. It takes my mind off the everyday routines and helps me deal with my father's cancer. Also gives me a reason to get involved with forums like this one.
    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
    • By Randel1
      Product warning:  Lighting products manufactured by Larson Electronics LLC  9419 E US HWY 175, Kemp Tx. 75143
      Hi, I’m G. Randel and I have a small business that does boat and motor service and repair and rigging. I also service and repair off road 4 wheelers, lawn equipment and small engines. I have been doing this type of work for over 40 years, so I have accumulated some knowledge about the accessories and products needed to support those things. 
      I recently installed two high intensity LED lights on the T-top of one of my customers boats. He bought the lights after he had done considerable research and consultation with manufacturers. He wanted to make sure he was getting something that would serve his needs which was to see where he was going at night while underway on the water.  He decided on lights manufactured by Larson Electronics out of Kemp, Texas. They were reported to be rugged, weatherproof, waterproof to 3 meters and were warrantied against workmanship or component failure under normal use for 3 years. One light quit working within 10 months, the other is still working after about 16 months.  I removed the defective light and sent it back to Larson Electronics for warranty repair or replacement and they denied the warranty claim. Their reason was “failure was due to environmental damage”.
      At the time of purchase these lights sold for over #365.00 each and the representative that my customer talked to at Larson Electronics assured him that these lights were well suited for the purpose in which they were going to be used. 
      So, if you are looking for electronics, as in lighting, for your ATV, SUV. Boat, or any other outdoor application you might want to keep in mind that Larson Electronics LLC
      9419 E US HWY 175, Kemp, TX 75143 might not fulfill their warranty claims if you have a problem with their products.
       
    • By xXDaveXx
      https://www.amazon.com/Primary-1998-2005-Polaris-Sportsman-Braking/dp/B01G2EEUV2
      Anyone ever try these? $500 for a OEM clutch seems high, But $120 seems a little cheap to me. Has anyone tried one with good luck? 
    • By dirtjunkie85
      Just wanted everyones opinon on riding glove I do long desert races and none of the glove i have wore seem to hold up really good they always wear fast and dont do much to prevent blisters any advice thanks.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...