Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Mike Foreman

New to Quads and lovin it!

Recommended Posts

That’s a good idea.   The relays go bad over time.   That is a newer bike so I’m a little surprised but anything’s possable.   

Ignition switches go bad all the time.  Especially when they are in bad locations.    Polaris was putting them on the right side of the bike in front of the gas tank. Not sure on the outlaw but could be just wet and oxidized inside.  

Share this post


Link to post
Share on other sites


On 12/6/2018 at 9:30 PM, Mike Foreman said:

imageproxy.php?img=&key=01ee6617cc17ea3cimageproxy.php?img=&key=01ee6617cc17ea3cimageproxy.php?img=&key=01ee6617cc17ea3ccurrent state. Don’t see any safety switches on the parts breakdown for this model. imageproxy.php?img=&key=01ee6617cc17ea3c

FE95B307-619E-4790-9A12-5F156FC450B7.jpeg

855CA5B1-733F-4C15-BC93-DBD7F2A8E9D7.jpeg

1FF25FBA-BB64-4D66-9187-B1849DD5CFB9.jpeg

D39659F6-F1BF-4595-A89D-0F307FCCF9FC.jpeg

2725A02F-461E-40C2-A97D-6802EC2E81D9.jpeg

06C254D5-094A-4DE0-933F-7BE87D9A0A2D.jpeg

looks like a really fun bike!

Share this post


Link to post
Share on other sites

Need to close this thread! 

So I had two issues- one was a dead cell and the other was the kill switch.  Replaced battery  and swapped out the switch for a 7.99 autozone waterproof switch.   Sodiered it back and glued it to the original plastic. Works great again.   Also swapped all brake shoes out and it stops again but the rear brakes on this Polaris really blow.  

ECCE26E4-97C0-4841-AFB9-B9E01063A988.jpeg

D0FCB803-6BC3-4BB7-AAAB-54AFAC7E64FA.jpeg

  • Like 1

Share this post


Link to post
Share on other sites


I'm not new to quads but new to this site.  Its a great thing having a love for ATV's.  Hopefully you got everything running.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • By StolenATV
      Stolen out of the drive way of Morgan Co. GA residents. Key was in in it and had a yellow keychains on it.
      The post Stolen Polaris Sportsman Twin EFI ATV appeared first on Stolen 911.
      View the full article
    • By Brer Wilson
      I got this almost a year ago for $500.00 it was covered in a garage and owned by a 57 year old lady.  She said she didn't need it anymore and wanted me to have it for my kids 1 of which is level 3 autistic.   Ritual oil changes and yearly service.  This was barely driven and when it was it wasn't beat on.  All in all I got a killer deal on this wheeler and nothing is wrong with it.  Starts and drives like its brand new. 

    • By Arby911
      I can't for the life of me find the correct service manual for this unit. It's air cooled, not liquid (oil cooler tho) and every manual I find has the wrong front differential diagram (it does NOT have a 2wd/4wd shifter).
      I'd be eternally grateful if someone could point me in the right direction. I can probably slog it out from some of the exploded diagrams I've found, but a good "do this, do NOT do that" manual would be a godsend.
      Regards,
      Ross
    • By Barry Wilford
      got a 350 big bear 4x4 about a 1988 not sure. need upper ball joint, but wales atv say only available with suspension arm . any thoughts appreciated.
       
    • By STEP MONSTER
      as soon as key is turned on 30 amp fuse blows. replaced battery & starter relay. no luck.
  • Recently Browsing   0 members

    No registered users viewing this page.


×