Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

kgard

adding power steering to Sportsman 450

Recommended Posts

Hi all, I bought a 2018 used 450 for my wife. She is having trouble with some of the real rocky trails close to our home. Her arms give out in an hour or two so I was thinking of adding power steering . Is this possible ? Anyone done this ? 

Share this post


Link to post
Share on other sites

Thanks Frank, I got a deal on this one with only 35 miles. A new one with EPS is around $6300 plus tax which I can't afford. I found a kit on Dennis Kirk and ATR for about $800.

Share this post


Link to post
Share on other sites

Did you get the kit installed? I’m considering adding SuperATV’s power steering kit to my 2016 Sportsman 570 and was wondering how the install would go. 

Share this post


Link to post
Share on other sites

Gotcha, from what I can tell they perform as well as the factory EPS units but take at least half a day to install. I’ll let you know if I end up getting it done on my wheeler. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jwline
      Friday evening went riding, rode for a good hour or so everything was fine. I went to take a short ride to the restroom (less than 100 yds away) and all of the sudden everything flickered and then just died out. Accompanying the problem I noticed the killswitch completely locked up. Once daylight hit took the killswitch apart to find it had shorted out and melted the plastic inside. Has anyone else had anything similar to this and if so what did you do to fix the situation? I have a new killswitch on the way to replace the obvious problem but was wondering could there be a bigger issue at hand. We tested with a voltage meter to make sure everything was still getting power from the battery and as far as we could tell it was.
      Any advice/info would be GREATLY appreciated.
      Thanks.
    • By JJ78
      I have a yamaha big bear 400, tested all fuses and relays. When I turn on key I get nothing, no neutral light or headlights. Could it be the key switch bad?
       
    • By mjm4jc
      Hello everyone,
      My Suzuki LT185 didn't come with a battery from the factory (no electric start). I was wondering if I would need to add a battery if I wanted to install some of those light bars/pods or should I just wire it in to the headlight switch? Will the generator be able to put out enough juice to run the light bar? Also, is it normal for the headlight to get dim at idle, then brighter when driving? Never had a quad before with just a generator. 
      Thanks!
    • By erkme73
      I recently purchased the subject UTV for my kids.  It's my first Polaris (other wheeler is a Teryx4) - and my first-ever single-cylinder vehicle (even my mower has more)...
      Valve lash adjustment values... The operating manual recommends verifying at specific intervals, but does not provide the clearances or procedure.  Any idea where I can obtain those? Tach on the display shows about 1500RPM when at idle, and about 6000 when WOT at max speed (30MPH).   Does that seem correct? The engine does not SOUND like it's going that fast, but that may just be my unfamiliarity with single-cylinder engines.  The idle feels mildly rough - and the tach shows a fluctuation of about 50 rpm.  It's not wild, but it is noticeable.  Again, without any point of reference, I do not know if that's just the nature of the beast, or if I should be concerned. The front wheels spin freely in the forward direction (mild brake noise can be heard), but when rotating tires backwards, the brake pads grab the rotor with significant force - making it nearly impossible to turn the rotor by hand.   Considering the cost of new rotors and calipers, I'm hoping there is a know 'fix' for this issue. Any help would be appreciated!  My kids can't wait for me to give it the "all clear".   Still waiting on helmets to arrive from Amazon, so I have a couple of days to get all the maintenance and repairs completed.
    • By Brent Wright
      I give it gas then it dies.any advice to fix?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...