Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

gregorio

New guy from NorCal

Recommended Posts

Hi all- new guy here.  Love everything with 4 wheels, ATV/Quads, Golf Carts, Jeeps, Race Cars, etc.  Rarely is anything I own stock and if it is, it is usually a factory hot rod! My daily drivers for the 1/4 mile commute to work are either a 2006 Polaris Sportsman X2 500 EFI or a 30MPH lithium powered Club Car Precedent!

 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Venom
      I am working on a friends 2006 Suzuki LT-Z50 that they purchased not running. I took apart the carb to rebuild it and someone had already been in there... They really destroyed the Air/Fuel Mixture opening in the body of the carb.. It is in no way repairable.
      I have not been able to find an aftermarket carb to fit this model.
      Does anyone know if an aftermarket carb is available?
      Thanks for any help.
    • By cgilley
      Ran it out of gas last month... Works fine for 3 or so days then refuses to start.... Changed out the sparkplug and it will run for 15 or so seconds before shutting off.... Cleaned out the fuel system and injector and it misses when idling as well as shutting off at idle every so often... It is giving me no other issues and sounds and runs fine while riding... Only issue is cutting off at idle.....
      Ideas anyone??
    • By Corky L Leazier
      One day went to start and nothing, the fan comes on cause its straight wired ,but no lights and no all the fuses show no power with the switch on. Changed starter relay nothing changed thinking maybe switch next and how can I test it.
    • By raymonday1115
      Hey I'm looking at purchasing a 2006 Arctic Cat 650 H1 SE but don't know much about Arctic cats, how reliable are they and will it make a good Mudder/work horse?
       
      Here is a link to the one I'm looking at
      https://www.kijiji.ca/v-atv/edmonton/2006-arctic-cat-650-h1-se/1507897599?utm_source=com.atomczak.notepat&utm_medium=social&utm_campaign=socialbuttons&utm_content=app_android
       
      Sent from my LM-Q910 using Tapatalk
       
       
    • By Bigobuck
      Hello,
      Wondering what other years and/or models my 2006 Polaris 330 Trail boss shares a transmission with, I need to replace mine, thanks!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...