Quantcast
Jump to content

15 Gallon Spot Sprayer for ATV


Recommended Posts

On 5/3/2020 at 6:12 PM, Dennis Martin said:

That's a heck of a deal!

I just bought this commercial quality sprayer from a farm sprayer supplier.  Really a heavy duty well made rig.  30' swath.  But almost $500.  

https://www.agspray.com/livestock-equipment/rangeland-pasture-sprayers/pid11288/25-gal-boomless-atv-sprayer-12v-pump/

Nice, looks like its a heavy duty sprayer.

Link to comment
Share on other sites

  • 7 months later...
  • 8 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By mehim
      Hi everyone. 
      Let me explain the thread title. 
      My husband and I are very active in the nudist community, and we have stayed at many and most of the mainstream nudist and clothing optional campgrounds in the USA. We are now approaching our retirement and would like to start a podcast to share those off the road / backwoods / little known camping areas where nudity is allowed. We have purchased a 5th wheel camping trailer with a rear garage for the ATV and now need some good reports on the one to buy. 
      We are most interested in a side by side unit but would love to get your thoughts. 
      Feel free to stop by and say Hi and ask anything you would like to better understand what we are looking for in an offroad unit. 
      Thanks for reading and hope to hear from you. 

    • By hardcastle
      My friends KQ 300 starts fine and runs, as soon as you put it in gear and try to accelerate its bucks and farts like crazy, not moving... I cleaned carb and it worked good for 1 day... now back to same problem.... could it be such as a bent valve????
    • By kiriyaaoi
      Hello everyone, I just picked up an 02 LT-F250F the other day and have been in the process of tearing it down to fix some stuff- one of which was the cylinder base gasket leaking like a sieve. Well, I know why that is now, and I also discovered that someone had been in there before. I didn't take pictures, but it looks like it was probably run low on oil at some point, the cam journals and the "bearings" (for lack of a better term) in the head and the valve cover are totally wiped out, very deep grooves.  From what I know it's very difficult to repair aluminum in this way, so I'm trying to figure out where to go next.
       
      1. Have someone grind down the head and valve cover and fit actual bearings in since the aluminum is screwed, and have the cam ground down to match.  I have no idea what this would cost.
      2. Buy a replacement head+cam+valve cover.
       
      #1 I was hoping someone might have some advice on, but #2 seems like it'll (probably) be the more cost effective option.  However I'm running into some difficulty, it seems like the 2001 and 2002 models specifically use a different head part number,  11100-19B10, instead of  11100-19B01 like for all earlier models.  What exactly is the difference between them? There are obviously far more of the earlier heads because it ran for over 10 years.  Are they actually interchangeable? I've also noticed there are heads from the LT250EF that has 4 valve heads but also otherwise look identical.  Would those work as well possibly?  I'd like to not have to drop $500 on machine work or new heads on a $1300 quad that I'm already putting a bunch of new parts on.  Oh, and it has a new piston and the cylinder itself looks pretty good too, as I said someone was in here before me.
       
      Any help or advice would be greatly appreciated. I'll post pics of the carnage tomorrow.
         
       
    • By Tuzz
      Bucking started about a month ago and works ok after 1/2 hour warmup.  Today while working on it i discovered that if i put the ignition switch in LIGHT position it runs fine right from the start.
      I'm stumped!  Any idea why this could be?  

    • By McG75
      Hello I’m new here and was wondering is anyone knew of good replacement part numbers for front struts and rear shocks for this atv? I think I’ve found a new rear shock, that looks like the original but there is no dimensions or anything and was wondering if there are any afterMarket new front struts available. I know it’s a long shot but any help would be appreciated. 
×
×
  • Create New...