Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

daveflew

4x4 problem Polaris 500 H0

Recommended Posts



is it push button to go into 4x4? if so, I'd check wires. also make sure you're in N. Also, make sure your battery is fully charged, sometimes you ATV will act like it has enough juice, but it doesn't have the amount to juice the electric shift. you could also use a tester on the wires, see if it's sending power to it. if it's a manual shift, i would check all of the linkage, i dont know how 4x4 ATV work, I've never owned one it might go to a transmission, but most likely a transfer case? if so that could have gone bad, or bad weather is hurting it.

Edited by Sparrows

Share this post


Link to post
Share on other sites

im almost positive it is electric switch if so check fuses... check wires going to and from the handlebar switch make sure none of them have been damaged due to sticks or other things... check ur diff make sure no wires from their r loose...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×