Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Ajmboy

UFO over Jerusalem?

Recommended Posts



The old saying, believe none of what you hear and only half of what you see, kinda goes out the window since the internet&photoshop arrived on the scene. Can't even believe any of what you see anymore.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Josh Boyd
      I have replaced the cdi box,spark plug,coil and stator but still no spark.
    • By Aj Hurtibise
      I have a 2000 Honda trx90 I got from a buddy for free he said it needed a carb so I put his old carb back on it to try to get something out of it and it does not have any Spark. I already replaced the ignition coil I don't know much about four wheelers but I am a technician so I do know my way around a motor any electrical help would be wonderful or specs I don't have the best digital multimeter either.
    • By Glen Motbey
      Hi Guys,
      I pick up an old 89 Yamaha Pro Hualer and its got no spark. Theres no power coming out of the CDI unit to the coil. Does anyone know how to or if you can check the cdi unit? Does anyone know where I could get a replacement one? Thanks Ben
    • By ken hathaway
      Tried to start my 850HL the other and had no spark. Changed the plugs, but while checking for spark noticed not getting fuel either. So no spark and no fuel. ECU? Anyone else have anything like this?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...