Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2006 polaris sportsman 450 "engine hot"


BKW78
 Share

Recommended Posts

The "engine hot" warning keeps flashing even when the bike is off for several hours. i unplugged the temp sensor and had it tested. It appears to be fine. With this warning flashing the fan wants to run all the time. I have not been able to locate a wiring diagram on the net, is there a relay that could be stuck?

Link to comment
Share on other sites

if your fan is running all the time then there is nothing wrong with yourwiring. back wash your rad by pulling out the fan. if than is good then check your brakes. if you have a caliper dragging then you can overheat the engine. you can also do a coolant flush. if your fuel mixture is a little lean it will cause it to overheat. if all of these are ok then i would buy a manual. if your plug gap is to wide it will do it as well. if you put to hot of plug in it will do it as well.

Link to comment
Share on other sites

Appearing to be fine and being fine are two different things, electrical components may be bad even if they test ok. How long does the machine run before you get the warning light? If it comes on immediately, I would say the either the sensor is malfunctioning or you may have a short in the wiring. If the light doesn't come on until the machine has been running for a while, then you may just be running hot. Make sure you have plenty of coolant and clean oil. How does it run, do you have any performance problems?

Link to comment
Share on other sites

I haven't rode the bike for 3 days. When I turned the key on the "HOT" warning starts flashing the oil was changed and the coolant level is correct. The bike runs fine even with the light flashing, the fan just runs all the time even with the key off

Link to comment
Share on other sites

  • 3 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...