Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

Kazuma Falcon 90 Help


Recommended Posts

my buddy gave me a kazua falcon 90 that he had let sit for 2 years. i cleaned fuel systems took apart and cleaned carb ,ohmed out all wires, safties, cdi, etc... it is so inconsistant its weird. sometimes it will crank good idle good and run till it warms up and then die and not start back up. sometimes it wont even start. sometimes it will crank but not idle good for nothing.. sometimes it wont crank or do anything... also the carb seems to have no response to any adjustments. olny thing is i have not replaced the plug.. ps thank for lettin me be a member yalls site kicks as* my kids and i are just getting in to wheeling so i hope to have a big one for myself soon an help would be appreciated thanks

Link to comment
Share on other sites

thanks for reply bud!!!! well i took carb apart again and cleaned again and replaced plug plug wire aq

nd plug boot now it cranks everytime and idles great infact i let it idle in shop last night for 2 hrs and it never shut off!!! olny problem now is it wont rev high rpm it wants to stall everytime u gas it i might need to adjust fuel air mixture on carb any ideas on that again yhanks for ur reply yall rock

Link to comment
Share on other sites

  • 1 year later...
My Kazuma 90 is smoking white smoke out the tail pipe bad. Is it what I think it means? For a car this means either rings or a head gasket but what about the Kazuma 90? Anybody know?

Depends how much...blue smoke is oil.

Please start a separate thread on this.

Link to comment
Share on other sites

  • 9 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By kawasig
      Hello there
      I'm having a problem finding a quality carburetor for a 1993 Suzuki Quad Runner lt-f 250 2x4. I find a lot that have 3-4 star ratings. And all so far don't have the right throttle Cable inlet at the top. The last one I got 4 star on Amazon has a threaded cable sheath rest that could be partially drilled to work. I would prefer to get one I don't have to modify. Any recommendations are greatly appreciated!
    • By p5200
      I added more fresh gas it sat one day now, it's acting up again. Before cleaning out carburetor it wouldn't idle good and had gas leaks from carburetor. Now it idles pretty good but, if I increase throttle speed at a certain amount it starts missing bad. I'm going to try and post a short video. Just about ready to give up on this thing.😒  you can see reflection perking in video.

      20240217_114429.mp4
    • By p5200
      Hello folks, my machine wound up with I think water in the tank etc. It runs but speeds up and slows back down randomly. When not running I don't see gas dripping  from the drain nipple on bottom of float bowl and drain screw is closed tight. With normal idle speed I see no leaking. When the idle speed increases quite a bit on it's own, gas appears to start slowly dripping from float bowl drain nipple? I'm wondering if the carb is flooding and the gas is actually coming from higher up and just appears, to be coming out of nipple but, is actually running down the sides of the nipple? I put a kit in the factory Mikuni carb last year after sitting for a while and I think the gas in the jug I used had drawn moisture. I plan to pull the carb tomorrow and clean everything out. I was just curious if anyone else thinks it's probably something in the carb and is, acutally a flooding problem? Thanks Folks! 🙂
    • By skittle021
      So I've got a Hisun 550 (clone of a Yamaha Rhino 660) that I was doing some work on that required removing the CVT and it's housing. Upon attempting to reinstall the clutch, sheaves, etc, I found that the belt no longer fits - it's far too wide. None of the parts have been replaced, they're all OEM. Exactly the same parts as what I took off a few weeks ago.
      To be more specific, my belt is 1.25in wide, but the gap between the clutch and the primary sheave is only 7/8in wide. I'll include a few photos to explain.
      Has anyone ever experienced such a bizarre problem? Any help at all would be appreciated, I've been stuck on this for a month. I'm open to just about any suggestion.
      Photos: 







    • ATV Service Manuals
    • By skittle021
      So I've got a Hisun 550 that I was doing some work on that required removing the CVT and it's housing. Upon attempting to reinstall the clutch, sheaves, etc, I found that the belt no longer fits - it's far too wide. None of the parts have been replaced, they're all OEM. Exactly the same parts as what I took off a few weeks ago.
      To be more specific, my belt is 1.25in wide, but the gap between the clutch and the primary sheave is only 7/8in wide. I'll include a few photos to explain.
      Has anyone ever experienced such a bizarre problem? Any help at all would be appreciated, I've been stuck on this for a month. I'm open to just about any suggestion.
      Photos: 







  • Similar Tagged Forum Content

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...