Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Huntingman2706217

im sold on this place... theres a jeep section! lol

Recommended Posts

Ive got 3... ive owned 19 XJ's 4 MJ's 1 ZJ and 1 WK2 in my life... all those within the last two years except for the ZJ...

I just got the WK2 in Dec... its a Overland edition... all the goodies but didnt get 4x4... didnt ever see going offroad in a $50k vehicle when i got a rock crawler and a 4x4 DD... lol...

96 Cherokees on 2006 F250 axles... 5.38 gears... saving for full hydro steering... caged... 4.5in lift with SYE... 40in gumbo mudders... H1 two piece steel wheels recentered to 8x170 and rock rings...

my 90 comanche i blew the rear main seal in last month so i have the motor out and did a head gasket and every other little gasket while its out... pressure washed and painted... new clutch, floor pan, oil pan... all kinds of stuff... painted the engine bay and pull the harness that im going to go through and recover everything and fix anything wrong... also sealing it all up water right... doing a external slave bellhousing swap on it as well... tons of time and money... oh and a 97+ cherokee front end conversion... its just my DD and im restoring it like new basically... itll get painted probly next year...

ill try and get some pics up... i moderate over at cherokeeforum.com as huntingman2706217 so if anyone else drives cherokees we got a lot of info and tips!

76544d1321395111-frugal-ii-poor-mans-story-forumrunner_20111115_171142.jpg

DSC00084.jpg

DSC00094.jpg

DSC00044.jpg

XJ.jpg

DSC00084.jpg.aad618f88dbb3a733db4a53ea7629433.jpg

DSC00094.jpg.654391ad6fe8325c6ec7f2683f19fc59.jpg

DSC00044.jpg.1a02237b75abdbfd51c95efcedbd2968.jpg

XJ.jpg.c442824ca82dddb6f681848bf57b6f71.jpg

Share this post


Link to post
Share on other sites




Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By pokolbinguy
      Hi All,
      Following on from the brief interlude in the "introducing myself" thread....
       
      In a nutshell, I acquired a YFM250 Moto 4 (1991) for cheap recently with the previous owner citing "no spark, needs a new magneto coil and I don't have time to fix it"... anyway I am dubious that the magneto/generator is the issue and thinking more along the line of ignition coil as after a clean up of the magneto I was able to get a rather decent voltage reading off the magneto with pull start and resistence readings seem to check out that the magneto is all ok (all 3 x phases = 1.2 ohms and no run to ground)
      None the less I ordered a new Ignition coil and Magneto/generator coil and am waiting for them to arrive.
       
      In the mean time I cleaned up the current Magneto, popped in a new battery and sparkplug, checked out all the wiring harness, all seemed good except I came across the "neutral switch" wire was broken.
       
      After wiring up a new neutral switch wire, the neutral light now comes on  (small win) and the starter relay (attached to rectifier) now clicks. If I hit the starter switch on handle bar the starter motor spins and if I  pull the cord starter I get a spark on pull....YAY!! I'll try and attach a video below if possible.
       
      So onto the starter motor. Starter solenoid seems to work A-ok, even if it looks crappy and starter motor spins as it should when I hit the start switch....but here is my issue.
       
      When the starter motor runs it turns Cog #1 and Cog #2 (see photo below)....but the chain in the back of the starter which I assume is the timing chain, does not move and there is no apparent movement of the piston in the cylinder.
       
      If I turn it by hand (per photo) or with the pull starter however the chain moves and the engine turns. However cog #2 rotates but not fluidly with the "Crank" (part I turn by hand) for the lack of a better word to use if that makes sense?
       
       
      Is there a grub screw or similar on Cog #2 that fixes it to the center shaft to make it all turn when the starter motor is run? Could there be a part missing? Previous owner had the starter apart so could be possible?
       
      The outer/front part seems to be on a key-way so not sure how to remove this easily to check how Cog #2 is attached.
       
      What am I missing here?
       
       
       
       
       

      spark_baby.mpg


    • By Dan Tressler
      I have a 2018 Sportsman 570 SP Hunters Edition. I bought the quad new in August of 2018 and put around 20 miles on it with no issues. In early January of this year the quad was acting as if it had a bad battery even though it had been plugged into a tender. I checked the battery and it tested well so I took it to the dealership for warranty service. They had it for almost a month. They determined the quad had a bad EPS unit and swapped it out. Then they told me that the wire for the EPS needed to be updated as they could not program the new unit with the old wire. After the wire came in dealership told me they were still having troubles programming. After another week and a half they told me that they had consulted several times with engineers from Polaris and found a workaround and that the quad was ready for pickup. I contacted Polaris to inquire about the warranty being extended as it was in the shop for a month. They extended the 6 month factory warranty for an additional 3 months. I picked the quad up and the dealership said that the 2018 SP editions were known to have issue a with the EPS units but believed that they had fixed mine. I had it back for around a month and took it out a couple times for short rides and everything seemed fine. I parked it again for a few days and when I went to start it same issues (acting like the battery is no good and won’t start, when I jump start no power steering). Took it back to dealership and waiting to hear what the diagnosis is this time as well as their plan to fix this permanently. Just wondering if anyone else has had issues similar to mine or can give me some advice. Thanks in advance!
    • By StolenATV
      my stolen side x side i ask that anyone with info to call me please it’s worth $17,500 it was stolen from my camp on Pleasant Grove Chapparell Rd… Waynesboro Ms. It’s a 2011 Polaris Ranger Browning Edition it’s has two LED light bars one on the roof and one on bumper it’s camo in color. I am offering $1000 reward for information that leads to recovery of goods and capture of suspects…
      1-337-257-0391 any help would be greatly appreciated…
      The post Stolen 2011 Polaris Ranger Browning Edition appeared first on Stolen 911.
      View the full article
    • By StolenATV
      OUR 2012 POLARIS ATV, 4 SEATER ROBBY GORDON EDITION WAS STOLEN FROM OUR RESIDENCE DRIVEWAY IN ODESSA, FLORIDA ON NOVEMBER 9,2014. WITH LOW MILES AND EXCELLENT CONDITION, THIS ORANGE AND WHITE ATV COULD HAVE EASILY BE REPAINTED OR DECALED FOR A QUICK SALE ANYWHERE IN THE USA!
      IF YOU ARE A DEALER OR CONSUMER LOOKING TO BUY ONE WHO IS READING THIS, PLEASE LOOK AT SERIAL NUMBER IMMEDIATELY. WE ARE OFFERING A $2000.00 CASH REWARD FOR ANY INFORMATION LEADING TO THE RECOVERY OF THIS ATV.
      SERIAL
      4XAXE7EA7CB442087
      CALL 813-477-9977
      The post 2012 POLARIS ATV – ROBBY GORDON EDITION appeared first on Stolen 911.
      View the full article
    • By StolenATV
      black & Orange 2007 Yamaha 700R Raptor special edition
      with new Ambush back tires on it. has a Gopro sticker and mount on it by the handlebars
      The post 2007 yamaha 700 R Raptor special edition 4 wheeler appeared first on Stolen 911.
      View the full article
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...