Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

oxidized_black

2005 Suzuki King Quad 700 Manual

Recommended Posts



Thanks for the welcome,

Just bought a 07 LTA 700 from Beaverton, OR Tuesday. Have yet to take it out.

Thanks for the posted manual. I just bought one of these yesterday DOH! ;-/

I was hoping to find a 'Users Manual' just to see what the manufacturer recommends an 'average' owner to take care of and the frequency of maintenance etc. I find these manuals fill in gaps of general knowledge which the full blown service manuals assume the reader to know.

Any ideas?

Regards

Crispy

Share this post


Link to post
Share on other sites

Hey I have a 1997 Suzuki King Quad which suddenly began to run very rich at upper throttle. It would clear out when throttle was held wide open. It got progressively worse but would run that way intermittently. The Carb is a CV 19b9-k652 and of course I have been through the carb and every thing looks good. I have adjusted the needle up and down and while it does effect the way it runs it still seems to be running very rich. It runs well at idle to 1/4 throttle then when throttle is opened it gurgles and runs very rich. I have done everything I know. I have even changed the carb to an old keihin round slide just to check and it does the same thing. It is getting fuel from the tank and the pump seems to be working OK. Since I changed carbs and the different carb does the same thing I am beginning to think the problem lies somewhere else. I am an experienced motorcycle and auto mechanic but this has me stumped. In checking the Forums this seems to be a common problem on this particular machine. Has anybody out there found an answer to this problem. I hate to spend big bucks on a new carb and not solve the problem. Anybody that can help I will be very appreciative! Feel free to email me at [email protected] or call me 918 235 1861!

Thanks

Jay Rasco,

Share this post


Link to post
Share on other sites


I have this same manual for my suzuki, but I'm having a problem with the dashboard lighting, but it doesn't display anything. I've been looking for a wiring diagram and haven't been able to find it. I was told it is a black wire with red stripes that is broken but I don't have a wire that color. I've unwrapped most of the wiring and don't see anything wrong. Checked all the connections and no corrosion and they all test ok. I'm open to any suggestions anyone might have.

Thanks oxidized for the welcome!!

Leegaard

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By Dana Hudson
      Hey everyone, hoping to get some help here... my kids 03 KTF 50 Quad has always ran great... they were riding it a couple of hours a few days ago and it died a couple of times (not normal) but started right back up. A few days later my 5 year old wanted to take it for a spin so I started it (2 pulls) and he took off.. he made it a couple hundred yards and it died and we havnt been able to start it since. I have new gas, good spark and 120 psi compression.. it will not start with starter fluid in the intake or even in the cylinder.. the fuel bowl has fuel at the carb... what am I missing? It’s driving me crazy!!
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By BChesebro
      Looking for a service/repair manual for a 2000 Polaris 500 Magnum 4x4 
    • By Jason Magnone
      As stated above working on a 1999 Suzuki LT-F160. I think I’m having trouble with the carburetor. I keep fouling spark plugs. Full disclosure, I did make a poor attempt to “rebuild” the carb (that’s why I think that’s the issue). No idea if the new parts are at the correct “settings” (gaps and such) I believe the starting point is 1.5 turns from bottom out on the adjustment screw (is there another adjustment I don’t know of?).  Doesn’t feel like I’m getting gas drawn through the carb (clogged jet maybe?), the plug isn’t wet at all (assuming why they’re fouling?) Not a great deal of experience working on carbs and not having much luck on finding a lot of info on the 160’s.
      1st- by chance can I swap out the original carb (13200-02C03) for an LT 250 model (think the HA01050). They’re only about $30 apposed to $200. That would at least narrow down if it’s a wiring problem or carb issue.
      2nd - The wiring has been minipulated at least a dozen times (before I acquired it, my cousin got it from a buddy kind of thing). Hopefully don’t have to dig into this too much as it’s currently a bit if a mess. 
      I was told it ran last year... 
      Any imput would be greatly appreciated
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...