raybob

2000 Suzuki Quad Master 500 - Stalls

Recommended Posts

I have a 2000 quad master 500. sometimes it runs great,,,but sometimes will idle but will not take the gas it has to run with the key on with the lights if I turn it to on it dies. I put a new coil on yesterday it ran great for awhile then started it all over again. any help would be great. is there any way to check the stator. Thanks again Raybob in ky

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


When it dies out, you need to determine if it's spark or fuel related. Have you changed the plug/wire?

* Added year, manufacturer, and issue to thread title.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

changed the plug and coil still doing it. I dont understand why it will idle with the key in light position and dies when in the on position its got me thanks Raybob

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Bad ignition switch...especially if it's been run with a teather hanging off the key.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

how is your spark? if it's consistent fat and blue, your stator is ok. might be the cdi box ....

i would check all your wires and make sure they have good contacts ....

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


I ordered a new key switch like mud flap said. hope it works $100 thanks to everyone,, Raybob switch comes in friday I will let you know

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.
I ordered a new key switch like mud flap said. hope it works $100 thanks to everyone,, Raybob switch comes in friday I will let you know

will idle with switch on now but still will not take the gas quits when I give it gas, cleaned the carb, new ing switch,new coils fresh gas and new hoses is there anyway to check the cdi box. Thanks Raybob in ky

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  •  Like what you are reading? Please help us by sharing this content.