Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

wylde1

Playing in the snow and ice

Recommended Posts

:partyc:Got some snow to play in, but before I could get to it, once again sleet and freezing rain.:aargh: Well, I went ou to play in it anyway:ola: One thing led to another and I landed bad off of a jump.:brickwall: The Polaris ended up int the trees:no: and I ended up sleigh riding on my helmet.:wacko:Here is the helmet cam footage, hope you laugh as hard as I did.:laugh::biglaugh:

[ame=http://www.youtube.com/watch?v=97_E3k_WyoY]ATV Epic POV Crash - YouTube[/ame]

Share this post


Link to post
Share on other sites


:partyc:Got some snow to play in, but before I could get to it, once again sleet and freezing rain.:aargh: Well, I went ou to play in it anyway:ola: One thing led to another and I landed bad off of a jump.:brickwall: The Polaris ended up int the trees:no: and I ended up sleigh riding on my helmet.:wacko:Here is the helmet cam footage, hope you laugh as hard as I did.:laugh::biglaugh:

ATV Epic POV Crash - YouTube

lmfao nice one wylde1 :biggrin::biglaugh::biglaugh:

Share this post


Link to post
Share on other sites


Thanks guys, glad you like it. I seem to have problems with trees. I hit one in my first video I put on here too and it was the same result, everyone thought it was funny as hell.

Share this post


Link to post
Share on other sites
lol im glad i dont have that many problems with trees

I get a little crazy every now and then:yes:gotta leave off the throttle once in a while:huh:

Share this post


Link to post
Share on other sites

Lets vote for a name change for Wyld1 to George ( George george george of the jungle look out for that tree) Glade your ok I can trade you some warmer weather & mud for some snow.

Share this post


Link to post
Share on other sites

at least you are smart enough to ware your helmet and saftey gear ...lol.. alot of guys dont ..and that little spill could of really hurt some one that didnt wear there gear ...

KOOL.VID... AN BETTER LUCK NEXT TIME ...LOL..

Share this post


Link to post
Share on other sites


at least you are smart enough to ware your helmet and saftey gear ...lol.. alot of guys dont ..and that little spill could of really hurt some one that didnt wear there gear ...

KOOL.VID... AN BETTER LUCK NEXT TIME ...LOL..

:yes:yeah my neck brace saved me. I slid on the helmet until the camera dug in and flipped me. That would have hurt my neck without the support.:biggrin:

Share this post


Link to post
Share on other sites
Lets vote for a name change for Wyld1 to George ( George george george of the jungle look out for that tree) Glade your ok I can trade you some warmer weather & mud for some snow.

:mad:It's not my fault, they always put the trees to close to the sides of the trail.:aargh::laugh:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By Sha35297
      So, I got this 07' Polaris Outlaw 90 in the shop to rebuild top end and transmission. Replaced all bearings and gears in the transmission. Replaced cylinder and piston with brand new parts. Put the engine back on the frame and fired it up. Started great, but had a taping sound in the lower crank case. pulled the flywheel cover off and found the flywheel was wobbling and hitting the stator. I then replaced the stator and flywheel with brand new parts. Timing is all set on the timing marks now, but when I turn it over it kicks back when it fires and ends up stripping the starter idler gear. I've replaced the starter gear once already and now have to replace it again. Is it possible that the timing marks on the flywheel are off or maybe this flywheel is not for this exact model? Thinking of advancing the timing to try it, but don't want to keep going through idler gears.
    • By ATVNetwork
      news A powerful trail machine ready to tackle the hardest adventures.
      Polaris unveiled the 2021 Sportsman 850 Trail Edition ATV with factory-equipped enhancements to tackle the roughest terrain. View the full article
    • By Budman
      After purchasing a lightly used 2018 570SP (300 miles on it) I noticed that the display was flashing on and off. I remember reading awhile back that this was a common problem on the 18 model. I can't remember what the fix is. It also turns over slow even though the battery is charged. Anybody know what the fix is on this issue?
      Thanks
      Budman
    • By ezduzit
      New to me xpress i believe shuts down when put into reverse, but if i hold the override button it will remain running. 
      This is not normal operation based on my scramblers i've owned before. She also grinds when i attempt to select high gear and wont engage. lastly she runs great in low gear . I dont know how to fix this or where to begin my troubleshooting. 1994 polaris 300 2x4 thanks in advance for any suggestions/solutions
    • By technofarmer
      Hey there, i have recently put a new drive belt on my 11 Polaris Sportsman 500 H.O.    It has 44 miles since putting the new belt on and should be nearly broken in as i hear it takes 50 miles to do so?  Anyhow it has had a little trouble with slipping since i put the new one on a few months ago. Now whenver i go down a hill the belt seems to be getting caught in one clutch if not both and then it has to run a high rpm just to go a low speed.  Today it did that again going down hill, i stopped, put it in neutral and when going back up the hill i had to turn it off, put it in neutral, let it roll back down the hill a little, then restart it, low range and it was slipping but thankfully i was able to make it up the hill. 
       
       So what might the problem be? Is this a need for another new belt? New clutches and belt? Or just get something else? BTW the brand new belt i put on it, is a factory one, an exact replacement for the original.   

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...