Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

tgrider

Spark Arrestor for 1996 Kodiak 400

Recommended Posts

Howdy, Im not quite sure how to explain this. At the end of the muffler, inside, I guess it is the Spark Arrestor. Well it is completely loose and the screen is off and loose. But Im not sure how to get it out and how to put a new one in there. Im sure it is the original muffler but it seems in decent shape.

Does anyone have any suggestions? Also, whithout spending alot of money, are there any suggestions on what spark arrestor to purchase like a Universal one that just mounts to the end of the muffler with hose clamps or screws?

Thanks,

Edited by tgrider

Share this post


Link to post
Share on other sites

Save 5% on ATV/UTV Parts, Accessories & More at GearUp2Go.com! Use Code: WNTR5
Save 5% on ATV/UTV Parts, Accessories & More at GearUp2Go.com! Use Code: WNTR5

Save 5% on ATV/UTV Parts, Accessories & More at GearUp2Go.com! Use Code: WNTR5

Thanks for the Reply Ajmboy. Actually I emailed Rocky Mountian ATV and they said that I need Part # 6 which is called the Pipe, Outlet. It is the Spark Arrestor. It is $77.77 OEM Parts and OEM Motorcycle Parts for Dirt Bikes, ATVs and UTVs | Rocky Mountain ATV/MC

I was able to get the old Spark Arrestor out. I then cleaned up the parts and hosed clamped it back together. I then put it back in. At least it will get me by until I can afford to spend the money.

Thanks again for the Reply

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Chris Chitwood
      Hi, I’m a 16 year old that is wanting to get more into vehicle and mechanic repair. My dad has an old ‘96 Timberwolf that he doesn’t remember running since I was born. I want to get it running again as a memory for him and to help us be able to hunt together, and of course so I can learn how engines work more than the little information I know now. I’ve pulled the carburetor and gas tank off of it, and the carburetor is getting cleaned by a friend. I can post photos of the condition it’s in later, I’m just curious where I should start in my journey to get it running again. The power switch is broken off of the handlebar, so I am looking into fixing it, along with the pull cord. I’m afraid the engine is seized up, and I’m curious to hear any input anyone has. Thank you all.
    • By Craig Butterworth
      Hi, i'm looking for some help and advice with my arctic cat quad, its the first of the arctic cat quads as far as i know, manufactured in 1996 the bearcat 454. i have owned the quad for about 10 years now but just recently it has developed a problem with reverse gear, reverse wont engage any more like it used to 😕 the cable and handle is free but there is no movement the gearbox end, can anyone give me a heads up of what is involved to fix this? 🤔
      If anyone has a service/repair manual available for it as well that would be greatly appreciated! 🙂
    • By M0BJT
      Hi Everyone
      This is my first post and I was wondering if there is anyone who can help me solve a problem I have with my Yamaha Kodiak 400 4x4 Fitted with a Mikuni Carburetor . The year of the quad is around 1998, the reason I am not sure of the date is, there wasn't any paperwork and no details on the frame either.
      The quad had a bad leak from the carb overflow which indicated that the float needle valve was blocked or passing so I replaced this and put everything back together. The quad ran really well until I took it onto some rough ground to have a ride around, a few hours later the engine started to run really rough as if the engine was flooding. I have removed the carb again and cleaned the needle valve out and the whole of the carb just in case there where any dirt behind it. Engine now runs fine again but fuel has started to run out the carb overflow again.
      I have tried everything to try and stop the fuel leaking out the overflow but its still happening. My last thoughts where to adjust the float level and its still happening.
      Has anyone got any thoughts on the problem or could suggest whats causing the fuel leaking out the overflow.
      Thanks for reading
      Kevin
    • By Billie
      :confused:need a repair manual or help in what to look for thank you Bill
      for you muddober to make clear to you the neutral light and the gear light
      do not light up win shifting fuses are good Iuse my CAt for hunting im dissable the atv is my leag s thank you
    • By kiwisteve
      Hi Folks
      MY Ltf 400 has power and electric start turns motor over, but wont start...
      seems no spark
      im told stalled in paddock and wont start again
      any suggestions please
  • Similar Topics

    • By vtech
      I have a 1993 Bayou 400 4x4 and I have no spark. I tried 2 new plugs and nothing still.
      I have checked the CDI black wires to body of the box for continuity and none.
      It turns over but no spark, not sure where to go from there.
      Any advise on what and how to check other components would be awesome.
      Thanks: Garry
    • By texaskaw
      been acting up for a couple weeks.running fine then dies,no spark at plug.wait few minutes start up again runs for maybe hours.also sometimes it will run great then it starts losing rpm.will not wind up to higher rpms then it will pickup and go for awhile.well now there is no spark any time ,nothing....
    • By Michael P
      Hi i have bayou 400 when i turn it over i get one little spark and that's it? New cdi ,switch, and a used regulator/retifier,new battery any suggestions would be greatly appreciated
    • By JonBat68
      I have a 99 250 Quadrunner. Currently has no spark. It would run for 5 minutes, then shut off. After it cooled down about 20-30 minutes, it would start again. I ordered a new stator and found the old one was damaged (copper windings broken)  I installed the new stator, filled with oil and now it has no spark. Any assistance would be helpful
    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...