Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

remoore

Suzuki lt80 has me stumped!

Recommended Posts

This thing will not fire or even smoke. Spark looks good enough. So far I have replaced the plug (NGk), cleaned the flywheel-magneto, cleaned the carb & reeds, replaced both crank seals . Any input apreiciated. This things drivin me nuts!

Share this post


Link to post
Share on other sites


Is the flywheel on correctly ? Ive seen some small engines that allow you to install the flywheel 180 degrees off where it needs to be.

Share this post


Link to post
Share on other sites


This thing will not fire or even smoke. Spark looks good enough. So far I have replaced the plug (NGk), cleaned the flywheel-magneto, cleaned the carb & reeds, replaced both crank seals . Any input apreiciated. This things drivin me nuts!

Sounds like the same problem I had. It ended up being the intake valve was out of adjustment. In fact it wasn't moving at all. I put some play into it and it fired right up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Zmanyamaha
      Please help. Iv got an 1990 lt80 that will not charge the battery. I can’t seem to find the answer to the problem. Is it the rectifier or the Cdi box or something different all together. I can’t seem to find any rectifiers for it so I’m stumped and I don’t have a manual to read up and find the answer. 
    • By nix377
      Friend of mine picked up an LT80 that needs some work. The manufacture date is 11/1986
      The fuel and vacuum lines for the carb were all disconnected. I picked up a new card and was hoping someone on here has a photo or knows how the lines are hooked up
      Thanks in advance
    • By shar
      Picked up an LT80 (unknown year) for $200 recently for my girls. Not running at the moment, but does turn over. I’m thinking the carb needs to be rebuilt or replaced, as it appears to be leaking 2 stroke oil. Anyway, I’m excited to have something to wrench on in my (limited) spare time






    • By Admin
      View File 2002-2006 Suzuki LT80 Service Manual
      2002-2006 Suzuki LT80 Service Manual
      Submitter Admin Submitted 06/29/2019 Category Suzuki ATV  
    • By Admin
      2002-2006 Suzuki LT80 Service Manual
  • Similar Topics

    • By AKMichael
      Hello All,
      I have a 1999 Yamaha Big Bear 350 4x4 trying to get fixed up so my grandson can go out in the woods with me.
      We have owned it over 10 years.  It got harder to start, until it finally would not.  Replaced the carb.  Right afterwards, it started and ran nicely, but after turning it off, would not restart.  Tonight I used starting fluid and ran, then died.  Adjusted the idle up a little, used more starting fluid and ran great.  It idled about 15 minutes.  Turned it off, and restarted.  Ran it around the yard about 5 minutes.  Turned it off, and would not restart.
      Any ideas or suggestions would be greatly appreciated!
      Thank you. 
    • By vtech
      I have a 1993 Bayou 400 4x4 and I have no spark. I tried 2 new plugs and nothing still.
      I have checked the CDI black wires to body of the box for continuity and none.
      It turns over but no spark, not sure where to go from there.
      Any advise on what and how to check other components would be awesome.
      Thanks: Garry
    • By texaskaw
      been acting up for a couple weeks.running fine then dies,no spark at plug.wait few minutes start up again runs for maybe hours.also sometimes it will run great then it starts losing rpm.will not wind up to higher rpms then it will pickup and go for awhile.well now there is no spark any time ,nothing....
    • By Michael P
      Hi i have bayou 400 when i turn it over i get one little spark and that's it? New cdi ,switch, and a used regulator/retifier,new battery any suggestions would be greatly appreciated
    • By cody75
      2016 sportsman 450ho cranks. Good spark, removed injector getting fuel no check engine light no start
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...