Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Dirt Bike Forum

Sign in to follow this  

For all our dirt bike members, this is our dirt bike forum where you can post anything dirt bike related. 2 and 4 stroke dirt bike discussions.

Sign in to follow this  


  • Latest Forum Posts

    • Since you  found  corrosion  on the one terminal,  check all the others to the starter. Try jumping  directly  from the battery to the starter terminal.  If it spins over you  know it is a bad connection or  broken wire .  If it does not  the problem  is most likely in the  brushes in the  starter. Press the start button  and rap on the  starter . That will often  make the  brushes contact and spin the starter over ..  It  may continue to  work  for  a while after that ,  but if not  it  isn't  very difficult to  replace the brushes.
    • Check the groud conektion from the starter to groud,had the same problem,Olav from Norway
    • thanks for the reply Yes I did see it  and I checked that connector and everything looked Clean and was plugged in tight.  I finally got my parts yesterday and assembled the suspension on it so I’ll be able to take it for a ride this weekend I hope and I’ll see if the code clears or it it is affecting how it’s running   
    • You can download the entire pdf free once you get to 10 posts or if you don't want to post you can update your membership for immediate access. https://www.quadcrazy.com/subscriptions  
    • I would agree with @06kfx440 on that. Is this the winch and is that the plate? Also, is it remote only or is there a wired switch you can install? Just curious.

×
×
  • Create New...