Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Finsdad

2005 Suzuki King 700 Fuel????

Recommended Posts

I have a 2005 Suzuki King 700 and just bought my son a CanAm DS70. My king runs fine, the DS is cold natured as crap. Im wondering what fuel you guys are running? Im thinking Im going to get the ethanol free gas, or run sea foam in the ethanol gas. I know that either should be better than straight 87 with ethanol. What says you?

Share this post


Link to post
Share on other sites


I used to have a king quad 700 and always ran 93 octane in it as well as my yamaha grizzly now. 😁

  • Like 1

Share this post


Link to post
Share on other sites

What did you think of the King Quad?? The only other ATV I have owned is a Predator 500. Personally the King has tons more power. I have been going thru it and so far I like what Im finding

Share this post


Link to post
Share on other sites
1 hour ago, Finsdad said:

What did you think of the King Quad?? The only other ATV I have owned is a Predator 500. Personally the King has tons more power. I have been going thru it and so far I like what Im finding

I loved my king quad but had to sell it when I got married because we needed the money. Ended up buying a yamaha grizzly a couple of years later for a good deal. Below is me on my king quad from the gallery section. That ATV would go through anything and had it up to 74 MPH in the snow on the roads during a storm.

 

Share this post


Link to post
Share on other sites

I use regular 87 gas, during the riding season, every two or three tanks Ill add a dash of seafoam.

Winter time, my girl does not ride at all, so then I add sta-bil  for the winter in all our machines.

 

Mike

 

  • Like 1

Share this post


Link to post
Share on other sites


Added YMM info to topic title and moved to Suzuki forum.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
    • By donerightautomotive84
      Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol
      Sent from my LM-Q720 using Tapatalk
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
    • By Venom
      I am working on a friends 2006 Suzuki LT-Z50 that they purchased not running. I took apart the carb to rebuild it and someone had already been in there... They really destroyed the Air/Fuel Mixture opening in the body of the carb.. It is in no way repairable.
      I have not been able to find an aftermarket carb to fit this model.
      Does anyone know if an aftermarket carb is available?
      Thanks for any help.
    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...