Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2010 Yamaha 450 Wolverine??


Finsdad
 Share

Recommended Posts

I have a 450 Wolverine with 500 miles on it. My question is are these known to not have a lot of pick up? It just doesn't seem like its fast out of the hole or top end. It has plenty of low end torque. I thought maybe the CVT belt might be worn....but it only has 500 miles on it. 

Link to comment
Share on other sites

Dream Car Giveaway
1 hour ago, Finsdad said:

I have a 450 Wolverine with 500 miles on it. My question is are these known to not have a lot of pick up? It just doesn't seem like its fast out of the hole or top end. It has plenty of low end torque. I thought maybe the CVT belt might be worn....but it only has 500 miles on it. 

Those always seems to me like a utility quad dressed in sport quad plastics. It's not going to be a rocket ship, but should be able to get up there in speed as most utility 400 and 450 quads I used to own a Yamaha Kodiak 450 and it was fine and had good low end but wasn't a speedster of the starting line. Now if it's slipping, that's another thing. Do you have it in 4WD or 2WD, if I recall there is a selector.

  • Like 1
Link to comment
Share on other sites

Measure the  belt width and compare  it to  a  new belt to  know  how  much wear  is on it .. 500 miles  of  hard  pull  will wear it  more  than  easy riding. The weight  it is  carrying  also  affects   its acceleration  and top  speed.  My  260  pound  butt on a  buddies  quad  with the  CVT transmission definitely  is  slower  than  it is  with his  150   pounds.

  • Like 1
Link to comment
Share on other sites

I didn’t have it in 4wd. I’m just wondering if it’s me or something wrong? It runs great just think it would have more pick up. I’m not comparing it to my 700 king quad but they are night and day different. It doesn’t seem like it wants to spool up quick.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...