Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Dravkracing

How to make a 2010 Polaris outlaw 50 faster

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By spock58
      I was reading another forum recently about fuel leaks and possibility of fire happening. Reminded me of an incident I had a few years ago while working at a Can Am dealership. The quad was a stolen & recovered Outlander 650 that had been tampered with. These quads have an electronic safety system, similar to their DESS system on the sleds. You cannot bypass the key switch and get spark without a computer with factory software. Anyway, I was trying to determine what was damaged since the thief had attempted to hot wire various electronic parts. I got all the extra wires removed and things looked back to stock. Pulled the spark plugs and was going to check for ignition and if the starter still worked. Well, they both worked alright and guess what - the cylinder was flooded with fuel! Instant flames with gas spraying all over...great!! I managed to use my hands to put out the fire, good thing I had on gloves (but choked they were ruined of course, haha). Seems it's possible to flood an engine with efi when you put power straight to the injectors, doh! As in much of life, you cannot take things for granted (I'd only seen carbs flood like that). And even though it had spark, the quad still needed a new ECM to run - that part alone was $1200. So lets hear your stories, crazy stuff happens every day I'm sure.
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By John conway
      My quad will start sometimes than just die well it’s running than won’t start again for a day , put in new battery same problem and it seems to drain battery any help would be great
    • By raybob
      looking to buy good used carb for suz 500 quad master, I got one from china it is junk let me know if you have one and price. thanks Raybob
    • By Rock Ledge Homestead
      I bought this four-wheeler used for my son's birthday last week. It wasn't running when I got it but after a new battery and some tinkering it has been running for 5 days probably 8-10 hours of run time. 
       
      Today after 1 hour  My son wanted to wash it, I showed him how to be careful not getting water near the engine. We were careful but after we washed it and let it dry the motor starts but the transmission slips and won't really go forward.  Even if I pick the back of the four wheeler up the wheels only go forward a tiny bit. It's as if something is slipping inside.   But it worked fine right before the wash.
       
      Not sure what brand. I was told it was 90 cc's the VIN is attached.  Is it 90 or 110ccs?
      No air filter came with it. Using a some old stockings until I figure out what air filter to order.
      My son is so bummed so I want to get it back up to speed but also teach him how to work on it.
       
      20200620_184911.mp4

  • Similar Tagged Content

    • By Austin Rowedder
      Hi I have a 2007 Polaris outlaw 525 irs and am trying to replace the needle bearings in the rear a arms. I was wondering how you go about getting the rubber seal and bearing out!?
    • By stinky
      I have an Outlaw 110 that will struggle to turn the engine over. Jump starting doesn't help other than the battery will drain LONG before the bike eventually starts, so is required. If you keep messing with it long enough it will eventually magically begin to crank fine and sometimes finally start. Once we finally get the bike to start and warm it up thoroughly, it will turn over and start just fine the rest of the day like nothing ever happened... next day it won't turn over again.  Internet research has found lots of people saying they replaced starters, starter clutch, wiring, etc. but with only about 50/50 success rate for their particular problems... and I never found anybody describing a problem like mine, so I'm looking for advice/experience. Would rather not just start blindly throwing parts at it. Does anybody have any thoughts/ideas?
    • By Ponetay
      I’m am trying to figure out how to set this to tdc so I can set the valves. Anyone know the procedure?
    • By Xyla Cat
      View File 2006 - 2007 Polaris Outlaw 500 Service Manual
      2006 - 2007 Polaris Outlaw 500 Service Manual.pdf
      Submitter Xyla Cat Submitted 08/25/2018 Category Polaris ATV  
    • By Xyla Cat
      2006 - 2007 Polaris Outlaw 500 Service Manual.pdf
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...